{"answers":{"affected":"2 open source packages ship an affected version, including github.com/cosmos/cosmos-sdk.","exploited":"There is no known exploitation of GHSA-23px-mw2p-46qm in the wild and no public exploit code.","fix":"Upgrade github.com/cosmos/cosmos-sdk to 0.46 or later.","what":"GHSA-23px-mw2p-46qm is a denial of service vulnerability in github.com/cosmos/cosmos-sdk, published on 6 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-23px-mw2p-46qm and fix it if it is affected.\n\nWhat it is: GHSA-23px-mw2p-46qm is a denial of service vulnerability in github.com/cosmos/cosmos-sdk, published on 6 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-23px-mw2p-46qm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/cosmos/cosmos-sdk (Go): affected all versions; fixed in 0.46\n- github.com/cosmos/cosmos-sdk (Go): affected all versions; fixed in 0.46\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-23px-mw2p-46qm/ (Markdown: https://insights.sbomify.com/GHSA-23px-mw2p-46qm/index.md)","id":"GHSA-23px-mw2p-46qm","markdown":"https://insights.sbomify.com/GHSA-23px-mw2p-46qm/index.md","name":"GHSA-23px-mw2p-46qm","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Cosmos SDK tool","requires_auth":"none","summary":"Attackers can cause denial of service or remote code execution on Cosmos validators using vulnerable Cosmovisor versions, especially with binary downloads enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"**Component**: Cosmovisor\n**Criticality**: Medium\n**Affected Versions**: Cosmovisor \u003c v1.0.0 (distributed with Cosmos-SDK \u003c 0.46)\n**Affected Users**: Validators and Node operators utilizing unsupported versions of Cosmovisor\n**Impact**: DOS, potential RCE on node depending on configuration\n\nAn issue has been identified on unsupported versions of Cosmovisor which may result in a Denial of Service or Remote Code Execution path depending on configuration for a node or validator using the vulnerable version to manage their node. \n\nIf a validator is utilizing an affected version of Cosmovisor with `DAEMON_ALLOW_DOWNLOAD_BINARIES` set to true, a non-default configuration, it may be possible for an attacker to trigger a Remote Code Execution path as well on the host. In this configuration it is recommended to immediately stop use of the `DAEMON_ALLOW_DOWNLOAD_BINARIES` feature, and then proceed with an upgrade of Cosmovisor.\n\nIt is recommended that all validators utilizing unsupported versions of Cosmovisor to upgrade to the latest supported versions immediately.  If you are utilizing a forked version of Cosmos-SDK, it is recommended to stop use of Cosmovisor until it is possible to update to a supported version of Cosmovisor, whether through your project’s fork, or directly compiled from the Cosmos-SDK. At the time of this advisory, the latest version of Cosmovisor is v1.5.0. \n\nAdditionally, the Amulet team recommends that developers building chains powered by Cosmos-SDK share this advisory with validators and node operators to ensure this information is available to all impacted parties within their ecosystems.\n\nFor more information about Cosmovisor, see https://docs.cosmos.network/main/tooling/cosmovisor\n\nThis issue was discovered by [Maxwell Dulin](https://maxwelldulin.com) and Nathan Kirkland, who reported it to the Cosmos Bug Bounty Program.  If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see [https://hackerone.com/cosmos](https://hackerone.com/cosmos).\n\n## How to tell if I am affected?\n\nRunning the following command will output whether your cosmovisor version is vulnerable to this issue or not.  \n\nVulnerable to this issue: \n\n```\nstrings ./cosmovisor | grep -q \"NEEDED at\" \u0026\u0026 echo \"vulnerable\" || echo \"NOT vulnerable\"\n\nvulnerable\n```\n\nNOT vulnerable to this issue:\n\n```\nstrings ./cosmovisor_new | grep -q \"NEEDED at\" \u0026\u0026 echo \"vulnerable\" || echo \"NOT vulnerable\"\n\nNOT vulnerable\n```\n\n*****\n\nA Note from Amulet on the Security Advisory Process\n\nIn the interest of timely resolution of this issue for validators and node operators, the Amulet team has chosen to use existing processes and resources for distributing security advisories within the Cosmos and Interchain Ecosystems. Stay tuned as we implement an improved, more robust security advisory distribution system that will provide equitable access to information about security issues in the Interchain Stack.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cosmos-SDK Cosmovisor component may be vulnerable to denial of service","id":"GHSA-23px-mw2p-46qm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.46"],"introduced":["0"],"last_affected":[],"package":"github.com/cosmos/cosmos-sdk","purl":null,"source":"GHSA-23px-mw2p-46qm"},{"ecosystem":"Go","fixed":["0.46"],"introduced":["0"],"last_affected":[],"package":"github.com/cosmos/cosmos-sdk","purl":"pkg:golang/github.com/cosmos/cosmos-sdk","source":"GHSA-23px-mw2p-46qm"}],"products":null,"published":"2023-09-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service or remote code execution on Cosmos validators using vulnerable Cosmovisor versions, especially with binary downloads enabled.","url":"https://insights.sbomify.com/GHSA-23px-mw2p-46qm/"}