{"answers":{"affected":"2 open source packages ship an affected version, including uptime-kuma.","exploited":"There is no known exploitation of GHSA-23q2-5gf8-gjpp in the wild and no public exploit code.","fix":"Upgrade uptime-kuma to 1.23.12 or later.","what":"GHSA-23q2-5gf8-gjpp is an authentication bypass vulnerability in uptime-kuma, published on 19 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-23q2-5gf8-gjpp and fix it if it is affected.\n\nWhat it is: GHSA-23q2-5gf8-gjpp is an authentication bypass vulnerability in uptime-kuma, published on 19 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-23q2-5gf8-gjpp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uptime-kuma (npm): affected all versions; fixed in 1.23.12\n- uptime-kuma (npm): affected all versions; fixed in 1.23.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-23q2-5gf8-gjpp/ (Markdown: https://insights.sbomify.com/GHSA-23q2-5gf8-gjpp/index.md)","id":"GHSA-23q2-5gf8-gjpp","markdown":"https://insights.sbomify.com/GHSA-23q2-5gf8-gjpp/index.md","name":"GHSA-23q2-5gf8-gjpp","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Uptime Kuma monitoring","requires_auth":"none","summary":"Enabling authentication in Uptime Kuma fails to invalidate existing sessions, allowing unauthorized access to previously authenticated users.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nThis is basically [GHSA-88j4-pcx8-q4q](https://github.com/louislam/uptime-kuma/security/advisories/GHSA-88j4-pcx8-q4q3) but instead of changing passwords, when enabling authentication.\n\n### PoC\n- Open Uptime Kuma with authentication disabled\n- Enable authentication using another window\n- Access the platform using the previously logged-in window\n- Note that access (read-write) remains despite the enabled authentication\n- Expected behaviour:\n  - After enabling authentication, all previously connected sessions should be invalidated, requiring users to log in.\n- Actual behaviour:\n  - The system retains sessions and never logs out users unless explicitly done by clicking logout or refreshing the page.\n\n### Impact\nSee [GHSA-g9v2-wqcj-j99g](https://github.com/louislam/uptime-kuma/security/advisories/GHSA-g9v2-wqcj-j99g) and [GHSA-88j4-pcx8-q4q](https://github.com/louislam/uptime-kuma/security/advisories/GHSA-88j4-pcx8-q4q3)\n\nTBH this is quite a niche edge case, so I don't know if this even warrants a security report.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Enabling Authentication does not close all logged in socket connections immediately","id":"GHSA-23q2-5gf8-gjpp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.23.12"],"introduced":["0"],"last_affected":[],"package":"uptime-kuma","purl":null,"source":"GHSA-23q2-5gf8-gjpp"},{"ecosystem":"npm","fixed":["1.23.12"],"introduced":["0"],"last_affected":[],"package":"uptime-kuma","purl":"pkg:npm/uptime-kuma","source":"GHSA-23q2-5gf8-gjpp"}],"products":null,"published":"2024-04-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Enabling authentication in Uptime Kuma fails to invalidate existing sessions, allowing unauthorized access to previously authenticated users.","url":"https://insights.sbomify.com/GHSA-23q2-5gf8-gjpp/"}