GHSA-23qp-3c2m-xx6w wasmvm: Malicious smart contract can crash the chain
A malicious smart contract can crash the blockchain network via a bug in the wasmvm library, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-23qp-3c2m-xx6w?
GHSA-23qp-3c2m-xx6w is a denial of service vulnerability in github.com/CosmWasm/wasmvm, published on 4 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
CWA-2025-001
Severity
Medium (Moderate + Likely)1
Affected versions:
- wasmvm >= 2.2.0, < 2.2.2
- wasmvm >= 2.1.0, < 2.1.5
- wasmvm >= 2.0.0, < 2.0.6
- wasmvm < 1.5.8
Patched versions:
- wasmvm 1.5.8, 2.0.6, 2.1.5, 2.2.2
Description of the bug
The vulnerability can be used to crash the chain. The underlying bug that causes this is present on both permissioned and premissionless chains, but it can only be triggered reliably with a malicious contract, so permissioned chains are much less likely to be affected.
(We'll add more detail once chains had a chance to upgrade.)
Patch
- 1.5: https://github.com/CosmWasm/wasmvm/commit/1151bc6df7d02d1889b8da37cf8510eaf4198eea
- 2.0: https://github.com/CosmWasm/wasmvm/commit/d4ff2adee44e6b9f7415a5dfbb3de745ab9b7678
- 2.1: https://github.com/CosmWasm/wasmvm/commit/8d44a286fabc793a2fba93752e58cd0fd5b88a2d
- 2.2: https://github.com/CosmWasm/wasmvm/commit/0aefa4c378457aeb3c07e7975b875be38872c56d
Applying the patch
The patch will be shipped in releases of wasmvm. You can update more or less as follows:
- Check the current wasmvm version:
go list -m github.com/CosmWasm/wasmvm - Bump the
github.com/CosmWasm/wasmvmdependency in your go.mod to one of the patched version depending on which minor version you are on;go mod tidy; commit. - If you use the static libraries
libwasmvm_muslc.aarch64.a/libwasmvm_muslc.x86_64.a, update them accordingly. - Check the updated wasmvm version:
go list -m github.com/CosmWasm/wasmvmand ensure you see 1.5.8, 2.0.6, 2.1.5 or 2.2.2. - Follow your regular practices to deploy chain upgrades.
While the fix for this issue is not consensus breaking, the patch contains another consensus breaking fix and requires a coordinated upgrade.
Acknowledgement
This issue was found by meadow101 who reported it to the Cosmos Bug Bounty Program on HackerOne.
If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see <https://hackerone.com/cosmos>.
Timeline
- 2024-11-25: Confio receives a report through the Cosmos bug bounty program maintained by Amulet.
- 2024-11-28: Confio security contributors confirm the report.
- 2024-11-28: Confio developed the patch internally.
- 2025-02-04: Patch gets released.
following Amulet's Severity Classification Framework ACMv1.2: https://github.com/interchainio/security/blob/0295254e8645301ccb606d46108a45cede0a73e0/resources/CLASSIFICATION_MATRIX.md ↩︎
Which versions are affected by GHSA-23qp-3c2m-xx6w?
12 open source packages ship an affected version, including github.com/CosmWasm/wasmvm/v2 and github.com/CosmWasm/wasmvm.
| Package | Affected | Fixed in |
|---|---|---|
github.com/CosmWasm/wasmvm/v2 Go | All versions | 2.0.6 |
github.com/CosmWasm/wasmvm/v2 Go | All versions | 2.1.5 |
github.com/CosmWasm/wasmvm/v2 Go | All versions | 2.2.2 |
github.com/CosmWasm/wasmvm/v2 Go | From 2.0.0 | 2.0.6 |
github.com/CosmWasm/wasmvm/v2 Go | From 2.0.0 | 2.0.6 |
github.com/CosmWasm/wasmvm/v2 Go | From 2.1.0 | 2.1.5 |
6 more packages
github.com/CosmWasm/wasmvm/v2 Go | From 2.1.0 | 2.1.5 |
github.com/CosmWasm/wasmvm/v2 Go | From 2.2.0 | 2.2.2 |
github.com/CosmWasm/wasmvm/v2 Go | From 2.2.0 | 2.2.2 |
github.com/CosmWasm/wasmvm Go | All versions | 1.5.8 |
github.com/CosmWasm/wasmvm Go | All versions | 1.5.8 |
github.com/CosmWasm/wasmvm Go | All versions | 1.5.8 |
How do I fix GHSA-23qp-3c2m-xx6w?
Upgrade github.com/CosmWasm/wasmvm/v2 to a fixed version for your release line: 2.0.6, 2.1.5 or 2.2.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is GHSA-23qp-3c2m-xx6w being exploited?
There is no known exploitation of GHSA-23qp-3c2m-xx6w in the wild and no public exploit code.
Sources
Also known as GO-2025-3448.