GHSA-23vw-mhv5-grv5 Denial of Service in @hapi/hapi
An attacker can crash the application by sending invalid CORS headers, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-23vw-mhv5-grv5?
GHSA-23vw-mhv5-grv5 is a denial of service vulnerability in @hapi/hapi, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Versions of @hapi/hapi prior to 18.4.1 or 19.1.1 are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.
Recommendation
Upgrade to versions 18.4.1, 19.1.1 or later.
Which versions are affected by GHSA-23vw-mhv5-grv5?
4 open source packages ship an affected version, including @hapi/hapi.
| Package | Affected | Fixed in |
|---|---|---|
@hapi/hapi npm | All versions | 18.4.1 |
@hapi/hapi npm | All versions | 18.4.1 |
@hapi/hapi npm | From 19.0.0 | 19.1.1 |
@hapi/hapi npm | From 19.0.0 | 19.1.1 |
How do I fix GHSA-23vw-mhv5-grv5?
Upgrade @hapi/hapi to a fixed version for your release line: 18.4.1 or 19.1.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is GHSA-23vw-mhv5-grv5 being exploited?
There is no known exploitation of GHSA-23vw-mhv5-grv5 in the wild and no public exploit code.