{"answers":{"affected":"4 open source packages ship an affected version, including @hapi/hapi.","exploited":"There is no known exploitation of GHSA-23vw-mhv5-grv5 in the wild and no public exploit code.","fix":"Upgrade @hapi/hapi to a fixed version for your release line: 18.4.1 or 19.1.1.","what":"GHSA-23vw-mhv5-grv5 is a denial of service vulnerability in @hapi/hapi, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-23vw-mhv5-grv5 and fix it if it is affected.\n\nWhat it is: GHSA-23vw-mhv5-grv5 is a denial of service vulnerability in @hapi/hapi, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-23vw-mhv5-grv5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @hapi/hapi (npm): affected all versions; fixed in 18.4.1\n- @hapi/hapi (npm): affected all versions; fixed in 18.4.1\n- @hapi/hapi (npm): affected from 19.0.0; fixed in 19.1.1\n- @hapi/hapi (npm): affected from 19.0.0; fixed in 19.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-23vw-mhv5-grv5/ (Markdown: https://insights.sbomify.com/GHSA-23vw-mhv5-grv5/index.md)","id":"GHSA-23vw-mhv5-grv5","markdown":"https://insights.sbomify.com/GHSA-23vw-mhv5-grv5/index.md","name":"GHSA-23vw-mhv5-grv5","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"An attacker can crash the application by sending invalid CORS headers, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `@hapi/hapi` prior to 18.4.1 or 19.1.1 are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.\n\n## Recommendation\n\nUpgrade to versions 18.4.1, 19.1.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in @hapi/hapi","id":"GHSA-23vw-mhv5-grv5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["18.4.1"],"introduced":["0"],"last_affected":[],"package":"@hapi/hapi","purl":null,"source":"GHSA-23vw-mhv5-grv5"},{"ecosystem":"npm","fixed":["18.4.1"],"introduced":["0"],"last_affected":[],"package":"@hapi/hapi","purl":"pkg:npm/%40hapi/hapi","source":"GHSA-23vw-mhv5-grv5"},{"ecosystem":"npm","fixed":["19.1.1"],"introduced":["19.0.0"],"last_affected":[],"package":"@hapi/hapi","purl":null,"source":"GHSA-23vw-mhv5-grv5"},{"ecosystem":"npm","fixed":["19.1.1"],"introduced":["19.0.0"],"last_affected":[],"package":"@hapi/hapi","purl":"pkg:npm/%40hapi/hapi","source":"GHSA-23vw-mhv5-grv5"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can crash the application by sending invalid CORS headers, causing a denial of service.","url":"https://insights.sbomify.com/GHSA-23vw-mhv5-grv5/"}