# GHSA-23vw-mhv5-grv5: Denial of Service in @hapi/hapi

> An attacker can crash the application by sending invalid CORS headers, causing a denial of service.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2020

## What is GHSA-23vw-mhv5-grv5?

GHSA-23vw-mhv5-grv5 is a denial of service vulnerability in @hapi/hapi, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of `@hapi/hapi` prior to 18.4.1 or 19.1.1 are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

## Recommendation

Upgrade to versions 18.4.1, 19.1.1 or later.

## Which versions are affected by GHSA-23vw-mhv5-grv5?

4 open source packages ship an affected version, including @hapi/hapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hapi/hapi` | npm | All versions | 18.4.1 |
| `@hapi/hapi` | npm | All versions | 18.4.1 |
| `@hapi/hapi` | npm | From 19.0.0 | 19.1.1 |
| `@hapi/hapi` | npm | From 19.0.0 | 19.1.1 |

## How do I fix GHSA-23vw-mhv5-grv5?

Upgrade @hapi/hapi to a fixed version for your release line: 18.4.1 or 19.1.1.

## Is GHSA-23vw-mhv5-grv5 being exploited?

There is no known exploitation of GHSA-23vw-mhv5-grv5 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-23vw-mhv5-grv5 and fix it if it is affected.

What it is: GHSA-23vw-mhv5-grv5 is a denial of service vulnerability in @hapi/hapi, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-23vw-mhv5-grv5 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hapi/hapi (npm): affected all versions; fixed in 18.4.1
- @hapi/hapi (npm): affected all versions; fixed in 18.4.1
- @hapi/hapi (npm): affected from 19.0.0; fixed in 19.1.1
- @hapi/hapi (npm): affected from 19.0.0; fixed in 19.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-23vw-mhv5-grv5/ (Markdown: https://insights.sbomify.com/GHSA-23vw-mhv5-grv5/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-23vw-mhv5-grv5

---
From sbomify Insights: https://insights.sbomify.com/GHSA-23vw-mhv5-grv5/
Summaries are generated and may contain mistakes; the official description above is the record.
