# GHSA-243q-g9j3-qf6r: non-admin users can create integration role with administrator role

> Non-admin users can escalate privileges by creating integration roles with administrator permissions, requiring an upgrade to the latest version.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2021

## What is GHSA-243q-g9j3-qf6r?

GHSA-243q-g9j3-qf6r is a vulnerability in shopware/core, published on 28 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact
non-admin users can create integration role with administrator role

### Patches
We recommend updating to the current version 6.4.1.1. You can get the update to 6.4.1.1 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

### Workarounds
For older versions of 6.1, 6.2, and 6.3 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659

## Which versions are affected by GHSA-243q-g9j3-qf6r?

4 open source packages ship an affected version, including shopware/core and shopware/platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.1.1 |
| `shopware/core` | Packagist | All versions | 6.4.1.1 |
| `shopware/platform` | Packagist | All versions | 6.4.1.1 |
| `shopware/platform` | Packagist | All versions | 6.4.1.1 |

## How do I fix GHSA-243q-g9j3-qf6r?

Upgrade shopware/core to 6.4.1.1 or later.

## Is GHSA-243q-g9j3-qf6r being exploited?

There is no known exploitation of GHSA-243q-g9j3-qf6r in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-243q-g9j3-qf6r and fix it if it is affected.

What it is: GHSA-243q-g9j3-qf6r is a vulnerability in shopware/core, published on 28 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-243q-g9j3-qf6r in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.1.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.1.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.1.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-243q-g9j3-qf6r/ (Markdown: https://insights.sbomify.com/GHSA-243q-g9j3-qf6r/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-243q-g9j3-qf6r

---
From sbomify Insights: https://insights.sbomify.com/GHSA-243q-g9j3-qf6r/
Summaries are generated and may contain mistakes; the official description above is the record.
