GHSA-2557-x9mg-76w8 ASA-2024-002: Default `PrepareProposalHandler` may produce invalid proposals when used with default `SenderNonceMempool` **Component**: C
An attacker can cause denial of service by submitting transactions with non-sequential sequence numbers, leading to invalid block proposals and reduced network production.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-2557-x9mg-76w8?
GHSA-2557-x9mg-76w8 is a vulnerability in github.com/cosmos/cosmos-sdk, published on 21 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
ASA-2024-002: Default PrepareProposalHandler may produce invalid proposals when used with default SenderNonceMempool
Component: Cosmos SDK Criticality: Medium Affected Versions: Cosmos SDK versions <= 0.50.3; <= 0.47.8 Affected Users: Chain developers, Validator and Node operators Impact: Denial of Service
Summary
When using the default PrepareProposalHandler and the default SenderNonceMempool, an issue was identified which may allow invalid blocks to be proposed when a single sender includes multiple transactions with non-sequential sequence numbers in certain conditions. If this state is reached, it can lead to a reduction in block production for a network.
Next Steps for Impacted Parties
If you are a chain developer on an affected version of the Cosmos SDK, it is advised to update to the latest available version of the Cosmos SDK for your project. Once a patched version is available, it is recommended that network operators upgrade.
A Github Security Advisory for this issue is available in the Cosmos-SDK repository. For more information about Cosmos SDK, see https://docs.cosmos.network/.
This issue was found by KonradStaniec, gitferry, SebastianElvis, and vitsalis who reported it to the Cosmos Bug Bounty Program on HackerOne on January 16, 2024. If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see https://hackerone.com/cosmos.
Which versions are affected by GHSA-2557-x9mg-76w8?
5 open source packages ship an affected version, including github.com/cosmos/cosmos-sdk.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cosmos/cosmos-sdk Go | All versions | 0.47.9, 0.50.4 |
github.com/cosmos/cosmos-sdk Go | All versions | 0.47.9 |
github.com/cosmos/cosmos-sdk Go | All versions | 0.47.9 |
github.com/cosmos/cosmos-sdk Go | From 0.50.0 | 0.50.4 |
github.com/cosmos/cosmos-sdk Go | From 0.50.0 | 0.50.4 |
How do I fix GHSA-2557-x9mg-76w8?
Upgrade github.com/cosmos/cosmos-sdk to a fixed version for your release line: 0.47.9 or 0.50.4.
Is GHSA-2557-x9mg-76w8 being exploited?
There is no known exploitation of GHSA-2557-x9mg-76w8 in the wild and no public exploit code.
Sources
Also known as GO-2024-2571.