{"answers":{"affected":"2 open source packages ship an affected version, including magento/community-edition.","exploited":"There is no known exploitation of GHSA-26hq-7286-mg8f in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to 1.14.3.2 or later.","what":"GHSA-26hq-7286-mg8f is a command injection vulnerability in magento/community-edition, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-26hq-7286-mg8f and fix it if it is affected.\n\nWhat it is: GHSA-26hq-7286-mg8f is a command injection vulnerability in magento/community-edition, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-26hq-7286-mg8f in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected from 1.9.0.0; fixed in 1.14.3.2\n- magento/community-edition (Packagist): affected from 1.9.0.0; fixed in 1.14.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-26hq-7286-mg8f/ (Markdown: https://insights.sbomify.com/GHSA-26hq-7286-mg8f/index.md)","id":"GHSA-26hq-7286-mg8f","markdown":"https://insights.sbomify.com/GHSA-26hq-7286-mg8f/index.md","name":"GHSA-26hq-7286-mg8f","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Magento e-commerce platform","requires_auth":"none","summary":"Remote attackers can execute arbitrary code on Magento 1 installations using sendmail with specific non-default configurations.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Zend Framework 1 vulnerability can be remotely exploited to execute code in Magento 1. While the issue is not reproducible in Magento 2, the library code is the same so it was fixed as well.\n\nNote: while the vulnerability is scored as critical, few systems are affected. To be affected by the vulnerability the installation has to:\n\n- use sendmail as the mail transport agent\n\n- have specific, non-default configuration settings as described [here](https://magento.com/security/patches/supee-9652#:~:text=settings%20as%20described-,here,-.).","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Magento Patch SUPEE-9652 - Remote Code Execution using mail vulnerability","id":"GHSA-26hq-7286-mg8f","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.14.3.2"],"introduced":["1.9.0.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-26hq-7286-mg8f"},{"ecosystem":"Packagist","fixed":["1.14.3.2"],"introduced":["1.9.0.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-26hq-7286-mg8f"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote attackers can execute arbitrary code on Magento 1 installations using sendmail with specific non-default configurations.","url":"https://insights.sbomify.com/GHSA-26hq-7286-mg8f/"}