{"answers":{"affected":"2 open source packages ship an affected version, including gradio.","exploited":"There is no known exploitation of GHSA-26jh-r8g2-6fpr in the wild and no public exploit code.","fix":"Upgrade gradio to 5.0.0 or later.","what":"GHSA-26jh-r8g2-6fpr is a vulnerability in gradio, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-26jh-r8g2-6fpr and fix it if it is affected.\n\nWhat it is: GHSA-26jh-r8g2-6fpr is a vulnerability in gradio, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-26jh-r8g2-6fpr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gradio (PyPI): affected all versions; fixed in 5.0.0\n- gradio (PyPI): affected all versions; fixed in 5.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-26jh-r8g2-6fpr/ (Markdown: https://insights.sbomify.com/GHSA-26jh-r8g2-6fpr/index.md)","id":"GHSA-26jh-r8g2-6fpr","markdown":"https://insights.sbomify.com/GHSA-26jh-r8g2-6fpr/index.md","name":"GHSA-26jh-r8g2-6fpr","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Gradio UI library","requires_auth":"none","summary":"Attackers can bypass dropdown input restrictions in Gradio applications by sending arbitrary values, potentially leading to further security issues.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n**What kind of vulnerability is it? Who is impacted?**\n\nThis vulnerability is a **data validation issue** in the Gradio `Dropdown` component's pre-processing step. Even if the `allow_custom_value` parameter is set to `False`, attackers can bypass this restriction by sending custom requests with arbitrary values, effectively breaking the developer’s intended input constraints. While this alone is not a severe vulnerability, it can lead to more critical security issues, particularly when paired with other vulnerabilities like file downloads from the user's machine.\n\n### Patches\nYes, this issue is addressed in `gradio\u003e=5.0`. Please upgrade to the latest version to resolve the problem.\n\n### Workarounds  \n**Is there a way for users to fix or remediate the vulnerability without upgrading?**\n\nTo mitigate the issue without upgrading, developers can add manual validation in their prediction function to check the received values against the allowed dropdown values before processing them.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Gradio's dropdown component pre-process step does not limit the values to those in the dropdown list","id":"GHSA-26jh-r8g2-6fpr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"business_logic","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"gradio","purl":null,"source":"GHSA-26jh-r8g2-6fpr"},{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"gradio","purl":"pkg:pypi/gradio","source":"GHSA-26jh-r8g2-6fpr"}],"products":null,"published":"2024-10-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass dropdown input restrictions in Gradio applications by sending arbitrary values, potentially leading to further security issues.","url":"https://insights.sbomify.com/GHSA-26jh-r8g2-6fpr/"}