{"answers":{"affected":"2 open source packages ship an affected version, including org.opensearch.dataprepper.plugins:geoip-processor.","exploited":"There is no known exploitation of GHSA-28gg-8qqj-fhh5 in the wild and no public exploit code.","fix":"Upgrade org.opensearch.dataprepper.plugins:geoip-processor to 2.12.2 or later.","what":"GHSA-28gg-8qqj-fhh5 is a vulnerability in org.opensearch.dataprepper.plugins:geoip-processor, published on 15 Oct 2025."},"fix_prompt":"Check this codebase for GHSA-28gg-8qqj-fhh5 and fix it if it is affected.\n\nWhat it is: GHSA-28gg-8qqj-fhh5 is a vulnerability in org.opensearch.dataprepper.plugins:geoip-processor, published on 15 Oct 2025. \nExploitation: There is no known exploitation of GHSA-28gg-8qqj-fhh5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opensearch.dataprepper.plugins:geoip-processor (Maven): affected from 2.4.0; fixed in 2.12.2\n- org.opensearch.dataprepper.plugins:geoip-processor (Maven): affected from 2.4.0; fixed in 2.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-28gg-8qqj-fhh5/ (Markdown: https://insights.sbomify.com/GHSA-28gg-8qqj-fhh5/index.md)","id":"GHSA-28gg-8qqj-fhh5","markdown":"https://insights.sbomify.com/GHSA-28gg-8qqj-fhh5/index.md","name":"GHSA-28gg-8qqj-fhh5","record":{"aliases":[],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThe GeoIP processor and Kafka source and buffer were using the deprecated \"SSL\" protocol identifier when creating SSL contexts, potentially allowing the use of insecure SSL protocols instead of modern TLS versions.\n\nMultiple Data Prepper plugins used `SSLContext.getInstance(\"SSL\")` which could potentially allow the use of deprecated SSL protocols (SSLv2, SSLv3) that have known security vulnerabilities. While modern Java implementations typically default to secure TLS versions even with the \"SSL\" identifier, explicitly using \"TLS\" ensures that only secure TLS protocols are negotiated.\n\nThe affected components were:\n\n* GeoIP Processor: The `DBSource.initiateSSL()` method used for downloading GeoIP databases from external sources\n\n* Kafka Plugin: Both `CustomClientSslEngineFactory` and `InsecureSslEngineFactory` classes used for Kafka client connections\n\nThis could potentially allow connections to negotiate weaker SSL protocols instead of enforcing modern TLS versions, reducing the security of data transmission.\n\n### Patches\n\nData Prepper 2.12.2 contains a fix for this issue.\n\n### Workarounds\n\nIf upgrading is not immediately possible:\n\n1. Ensure your Java runtime is configured to disable deprecated SSL protocols\n2. Use network-level controls to enforce TLS-only connections\n3. Use external tools to verify that deprecated SSL protocols are not allowed.","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenSearch Data Prepper uses deprecated SSL protocol identifier","id":"GHSA-28gg-8qqj-fhh5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":null,"year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.12.2"],"introduced":["2.4.0"],"last_affected":[],"package":"org.opensearch.dataprepper.plugins:geoip-processor","purl":null,"source":"GHSA-28gg-8qqj-fhh5"},{"ecosystem":"Maven","fixed":["2.12.2"],"introduced":["2.4.0"],"last_affected":[],"package":"org.opensearch.dataprepper.plugins:geoip-processor","purl":"pkg:maven/org.opensearch.dataprepper.plugins/geoip-processor","source":"GHSA-28gg-8qqj-fhh5"}],"products":null,"published":"2025-10-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-28gg-8qqj-fhh5/"}