{"answers":{"affected":"2 open source packages ship an affected version, including angular.","exploited":"There is no known exploitation of GHSA-28hp-fgcr-2r4h in the wild and no public exploit code.","fix":"Upgrade angular to 1.6.0 or later.","what":"GHSA-28hp-fgcr-2r4h is a cross-site scripting vulnerability in angular, published on 27 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-28hp-fgcr-2r4h and fix it if it is affected.\n\nWhat it is: GHSA-28hp-fgcr-2r4h is a cross-site scripting vulnerability in angular, published on 27 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-28hp-fgcr-2r4h in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- angular (npm): affected all versions; fixed in 1.6.0\n- angular (npm): affected all versions; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-28hp-fgcr-2r4h/ (Markdown: https://insights.sbomify.com/GHSA-28hp-fgcr-2r4h/index.md)","id":"GHSA-28hp-fgcr-2r4h","markdown":"https://insights.sbomify.com/GHSA-28hp-fgcr-2r4h/index.md","name":"GHSA-28hp-fgcr-2r4h","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm JSONP library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers by exploiting untrusted JSONP resource URLs in this npm library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"JSONP allows untrusted resource URLs, which provides a vector for attack by malicious actors.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting via JSONP","id":"GHSA-28hp-fgcr-2r4h","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"angular","purl":null,"source":"GHSA-28hp-fgcr-2r4h"},{"ecosystem":"npm","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"angular","purl":"pkg:npm/angular","source":"GHSA-28hp-fgcr-2r4h"}],"products":null,"published":"2019-06-27","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary scripts in victim browsers by exploiting untrusted JSONP resource URLs in this npm library.","url":"https://insights.sbomify.com/GHSA-28hp-fgcr-2r4h/"}