{"answers":{"affected":"2 open source packages ship an affected version, including nginxbeautifier.","exploited":"There is no known exploitation of GHSA-28xx-8j99-m32j in the wild and no public exploit code.","fix":"Upgrade nginxbeautifier to 1.0.15 or later.","what":"GHSA-28xx-8j99-m32j is a vulnerability in nginxbeautifier, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-28xx-8j99-m32j and fix it if it is affected.\n\nWhat it is: GHSA-28xx-8j99-m32j is a vulnerability in nginxbeautifier, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-28xx-8j99-m32j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginxbeautifier (npm): affected from 1.0.14; fixed in 1.0.15\n- nginxbeautifier (npm): affected from 1.0.14; fixed in 1.0.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-28xx-8j99-m32j/ (Markdown: https://insights.sbomify.com/GHSA-28xx-8j99-m32j/index.md)","id":"GHSA-28xx-8j99-m32j","markdown":"https://insights.sbomify.com/GHSA-28xx-8j99-m32j/index.md","name":"GHSA-28xx-8j99-m32j","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"npm package","requires_auth":"none","summary":"A malicious npm package version steals credit card and password data from web forms, requiring developers to upgrade and audit for data breaches.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Version 1.0.14 of `nginxbeautifier` contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to `https://js-metrics.com/minjs.php?pl=`\n\n## Recommendation\n\nIf version 1.0.14 of this module is found installed you will want to replace it with a version before or after 1.0.14. In addition to replacing the installed module, you will also want to evaluate your application to determine whether or not user data was compromised.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Malicious Package in nginxbeautifier","id":"GHSA-28xx-8j99-m32j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.15"],"introduced":["1.0.14"],"last_affected":[],"package":"nginxbeautifier","purl":null,"source":"GHSA-28xx-8j99-m32j"},{"ecosystem":"npm","fixed":["1.0.15"],"introduced":["1.0.14"],"last_affected":[],"package":"nginxbeautifier","purl":"pkg:npm/nginxbeautifier","source":"GHSA-28xx-8j99-m32j"}],"products":null,"published":"2020-09-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious npm package version steals credit card and password data from web forms, requiring developers to upgrade and audit for data breaches.","url":"https://insights.sbomify.com/GHSA-28xx-8j99-m32j/"}