{"answers":{"affected":"2 open source packages ship an affected version, including illuminate/view.","exploited":"There is no known exploitation of GHSA-297g-xg4h-7w4c in the wild and no public exploit code.","fix":"Upgrade illuminate/view to 7.1.2 or later.","what":"GHSA-297g-xg4h-7w4c is a cross-site scripting vulnerability in illuminate/view, published on 15 May 2024. It can be exploited over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-297g-xg4h-7w4c and fix it if it is affected.\n\nWhat it is: GHSA-297g-xg4h-7w4c is a cross-site scripting vulnerability in illuminate/view, published on 15 May 2024. It can be exploited over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-297g-xg4h-7w4c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- illuminate/view (Packagist): affected from 7.0.0; fixed in 7.1.2\n- illuminate/view (Packagist): affected from 7.0.0; fixed in 7.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-297g-xg4h-7w4c/ (Markdown: https://insights.sbomify.com/GHSA-297g-xg4h-7w4c/index.md)","id":"GHSA-297g-xg4h-7w4c","markdown":"https://insights.sbomify.com/GHSA-297g-xg4h-7w4c/index.md","name":"GHSA-297g-xg4h-7w4c","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel framework","requires_auth":"unknown","summary":"An attacker can inject malicious scripts into Laravel applications via Blade templating, potentially compromising user sessions or data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Laravel is prone to a Cross-site Scripting vulnerability in blade templating.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Laravel Cross-site Scripting vulnerability in blade templating","id":"GHSA-297g-xg4h-7w4c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["7.1.2"],"introduced":["7.0.0"],"last_affected":[],"package":"illuminate/view","purl":null,"source":"GHSA-297g-xg4h-7w4c"},{"ecosystem":"Packagist","fixed":["7.1.2"],"introduced":["7.0.0"],"last_affected":[],"package":"illuminate/view","purl":"pkg:composer/illuminate/view","source":"GHSA-297g-xg4h-7w4c"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can inject malicious scripts into Laravel applications via Blade templating, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/GHSA-297g-xg4h-7w4c/"}