{"answers":{"affected":"2 open source packages ship an affected version, including measured.","exploited":"There is no known exploitation of GHSA-29g5-m8v7-v564 in the wild and no public exploit code.","fix":"Upgrade measured to 3.2.1 or later.","what":"GHSA-29g5-m8v7-v564 is a path traversal vulnerability in measured, published on 15 Jul 2025."},"fix_prompt":"Check this codebase for GHSA-29g5-m8v7-v564 and fix it if it is affected.\n\nWhat it is: GHSA-29g5-m8v7-v564 is a path traversal vulnerability in measured, published on 15 Jul 2025. \nExploitation: There is no known exploitation of GHSA-29g5-m8v7-v564 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- measured (RubyGems): affected all versions; fixed in 3.2.1\n- measured (RubyGems): affected all versions; fixed in 3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-29g5-m8v7-v564/ (Markdown: https://insights.sbomify.com/GHSA-29g5-m8v7-v564/index.md)","id":"GHSA-29g5-m8v7-v564","markdown":"https://insights.sbomify.com/GHSA-29g5-m8v7-v564/index.md","name":"GHSA-29g5-m8v7-v564","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"unknown","non_default_config":false,"product_category":"Ruby caching library","requires_auth":"none","summary":"An attacker can read arbitrary files by manipulating inputs during Measured::Cache::Json class initialization in this Ruby library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nA path traversal vulnerability exists where an attacker with access to manipulate inputs when initializing the `Measured::Cache::Json class` would be able to instruct the library to read arbitrary files.\n\n### Patches\nUsers should update to the latest version.","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Measured is vulnerable to Path Traversal attacks during class initialization","id":"GHSA-29g5-m8v7-v564","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"measured","purl":null,"source":"GHSA-29g5-m8v7-v564"},{"ecosystem":"RubyGems","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"measured","purl":"pkg:gem/measured","source":"GHSA-29g5-m8v7-v564"}],"products":null,"published":"2025-07-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can read arbitrary files by manipulating inputs during Measured::Cache::Json class initialization in this Ruby library.","url":"https://insights.sbomify.com/GHSA-29g5-m8v7-v564/"}