GHSA-2ccx-cjjh-r2j8 MediaMTX affected by CVE-2026-27143 due to vulnerable dependency

Not scored Published

MediaMTX is affected by a vulnerability in its Go dependency, requiring an upgrade to a patched version.

Exploited in the wild
Not known
Login needed
Not stated
Attackable
Not stated
Victim action needed
Not stated
Fix
Available

What is GHSA-2ccx-cjjh-r2j8?

GHSA-2ccx-cjjh-r2j8 is a vulnerability in github.com/bluenviron/mediamtx, published on 6 May 2026.

Official description

Summary

Release 1.17.1 seems affected by CVE-2026-27143. golang 1.25.9 Seems to solve the issue. Is there any new release planned?

Details

See https://nvd.nist.gov/vuln/detail/CVE-2026-27143.

Which versions are affected by GHSA-2ccx-cjjh-r2j8?

3 open source packages ship an affected version, including github.com/bluenviron/mediamtx.

PackageAffectedFixed in
github.com/bluenviron/mediamtx GoFrom 1.15.01.18.0
github.com/bluenviron/mediamtx GoFrom 1.15.01.18.0
github.com/bluenviron/mediamtx GoFrom 1.15.01.18.0

How do I fix GHSA-2ccx-cjjh-r2j8?

Upgrade github.com/bluenviron/mediamtx to 1.18.0 or later.

Is GHSA-2ccx-cjjh-r2j8 being exploited?

There is no known exploitation of GHSA-2ccx-cjjh-r2j8 in the wild and no public exploit code.

Sources

Also known as GO-2026-4989.

Is GHSA-2ccx-cjjh-r2j8 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free