# GHSA-2ccx-cjjh-r2j8: MediaMTX affected by CVE-2026-27143 due to vulnerable dependency

> MediaMTX is affected by a vulnerability in its Go dependency, requiring an upgrade to a patched version.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Not stated
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Also known as:** GO-2026-4989

## What is GHSA-2ccx-cjjh-r2j8?

GHSA-2ccx-cjjh-r2j8 is a vulnerability in github.com/bluenviron/mediamtx, published on 6 May 2026. 

### Official description

### Summary
Release 1.17.1 seems affected by CVE-2026-27143. golang 1.25.9 Seems to solve the issue. Is there any new release planned?

### Details
See https://nvd.nist.gov/vuln/detail/CVE-2026-27143.

## Which versions are affected by GHSA-2ccx-cjjh-r2j8?

3 open source packages ship an affected version, including github.com/bluenviron/mediamtx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/bluenviron/mediamtx` | Go | From 1.15.0 | 1.18.0 |
| `github.com/bluenviron/mediamtx` | Go | From 1.15.0 | 1.18.0 |
| `github.com/bluenviron/mediamtx` | Go | From 1.15.0 | 1.18.0 |

## How do I fix GHSA-2ccx-cjjh-r2j8?

Upgrade github.com/bluenviron/mediamtx to 1.18.0 or later.

## Is GHSA-2ccx-cjjh-r2j8 being exploited?

There is no known exploitation of GHSA-2ccx-cjjh-r2j8 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-2ccx-cjjh-r2j8 and fix it if it is affected.

What it is: GHSA-2ccx-cjjh-r2j8 is a vulnerability in github.com/bluenviron/mediamtx, published on 6 May 2026. 
Exploitation: There is no known exploitation of GHSA-2ccx-cjjh-r2j8 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/bluenviron/mediamtx (Go): affected from 1.15.0; fixed in 1.18.0
- github.com/bluenviron/mediamtx (Go): affected from 1.15.0; fixed in 1.18.0
- github.com/bluenviron/mediamtx (Go): affected from 1.15.0; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-2ccx-cjjh-r2j8/ (Markdown: https://insights.sbomify.com/GHSA-2ccx-cjjh-r2j8/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-2ccx-cjjh-r2j8

---
From sbomify Insights: https://insights.sbomify.com/GHSA-2ccx-cjjh-r2j8/
Summaries are generated and may contain mistakes; the official description above is the record.
