{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-2ch6-x3g4-7759 in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.2.23 or later.","what":"GHSA-2ch6-x3g4-7759 is a missing authorization vulnerability in openclaw, published on 3 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2ch6-x3g4-7759 and fix it if it is affected.\n\nWhat it is: GHSA-2ch6-x3g4-7759 is a missing authorization vulnerability in openclaw, published on 3 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2ch6-x3g4-7759 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.2.23\n- openclaw (npm): affected all versions; fixed in 2026.2.23\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2ch6-x3g4-7759/ (Markdown: https://insights.sbomify.com/GHSA-2ch6-x3g4-7759/index.md)","id":"GHSA-2ch6-x3g4-7759","markdown":"https://insights.sbomify.com/GHSA-2ch6-x3g4-7759/index.md","name":"GHSA-2ch6-x3g4-7759","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenClaw chatbot library","requires_auth":"low_privilege","summary":"OpenClaw's command authorization incorrectly allowed conversation identifiers, enabling unauthorized users in a chat to execute privileged commands.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\n`commands.allowFrom` is documented as a sender authorization allowlist for commands/directives, but command authorization could include `ctx.From` (conversation identity) as a sender candidate.\n\nWhen `commands.allowFrom` contained conversation-like identifiers (for example Discord `channel:\u003cid\u003e` or WhatsApp group JIDs), command/directive authorization could be granted to participants in that conversation instead of only the intended sender identity.\n\n### Affected Packages / Versions\n- Package: `openclaw` (npm)\n- Affected versions: `\u003c= 2026.2.22-2`\n- Patched version: `2026.2.23` (released)\n\n### Details\nRoot cause: `resolveSenderCandidates()` in `src/auto-reply/command-auth.ts` always included `ctx.From` in candidate evaluation used by `commands.allowFrom` authorization checks.\n\n`ctx.From` is sender-like in some direct-message contexts, but conversation-like in channel/group/thread contexts. This mixed principal handling allowed conversation identifiers to satisfy sender-only authorization.\n\n### Impact\nIn affected versions, command/directive authorization could become broader than intended when operators configured `commands.allowFrom` with conversation identifiers, allowing unintended users in that conversation to run command-only/directive-only flows.\n\n### Fix\nMain branch now treats `commands.allowFrom` as sender-only:\n- `ctx.From` is no longer included as a general sender candidate.\n- `ctx.From` is only used as fallback when sender fields are absent and the value is not conversation-shaped.\n- Regression tests were added for conversation-id denial and direct-message fallback preservation.\n\n### Fix Commit(s)\n- `08e2aa44e78a9c946d97bea62304e6f533b8fa8e`\n\n### Release Process Note\n`patched_versions` is pre-set to the released version (`2026.2.23`). This advisory now reflects released fix version `2026.2.23`.\n\nOpenClaw thanks @jiseoung for reporting.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw's commands.allowFrom sender authorization accepted conversation identifiers via ctx.From","id":"GHSA-2ch6-x3g4-7759","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.2.23"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-2ch6-x3g4-7759"},{"ecosystem":"npm","fixed":["2026.2.23"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-2ch6-x3g4-7759"}],"products":null,"published":"2026-03-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"OpenClaw's command authorization incorrectly allowed conversation identifiers, enabling unauthorized users in a chat to execute privileged commands.","url":"https://insights.sbomify.com/GHSA-2ch6-x3g4-7759/"}