{"answers":{"affected":"2 open source packages ship an affected version, including auth0/wordpress.","exploited":"There is no known exploitation of GHSA-2f4r-34m4-3w8q in the wild and no public exploit code.","fix":"Upgrade auth0/wordpress to 5.3.0 or later.","what":"GHSA-2f4r-34m4-3w8q is an authentication bypass vulnerability in auth0/wordpress, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2f4r-34m4-3w8q and fix it if it is affected.\n\nWhat it is: GHSA-2f4r-34m4-3w8q is an authentication bypass vulnerability in auth0/wordpress, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2f4r-34m4-3w8q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/wordpress (Packagist): affected all versions; fixed in 5.3.0\n- auth0/wordpress (Packagist): affected all versions; fixed in 5.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2f4r-34m4-3w8q/ (Markdown: https://insights.sbomify.com/GHSA-2f4r-34m4-3w8q/index.md)","id":"GHSA-2f4r-34m4-3w8q","markdown":"https://insights.sbomify.com/GHSA-2f4r-34m4-3w8q/index.md","name":"GHSA-2f4r-34m4-3w8q","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress plugin","requires_auth":"none","summary":"Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to WordPress sites using the Auth0 plugin.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"**Overview**\nSession cookies of applications using the Auth0 Wordpress plugin configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.\n\n**Am I Affected?**\nYou are affected by this vulnerability if you meet the following pre-conditions:\n1. Applications using the Auth0 WordPress Plugin with version \u003c=5.2.1\n2. Auth0 WordPress Plugin uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. \n3. Session storage configured with CookieStore.\n\n**Fix**\nUpgrade Auth0/wordpress plugin to v5.3.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.\n\n**Acknowledgement**\nOkta would like to thank Félix Charette for discovering this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Auth0 Wordpress plugin Vulnerable to Brute Force Authentication Tags of CookieStore Sessions","id":"GHSA-2f4r-34m4-3w8q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.3.0"],"introduced":["0"],"last_affected":[],"package":"auth0/wordpress","purl":null,"source":"GHSA-2f4r-34m4-3w8q"},{"ecosystem":"Packagist","fixed":["5.3.0"],"introduced":["0"],"last_affected":[],"package":"auth0/wordpress","purl":"pkg:composer/auth0/wordpress","source":"GHSA-2f4r-34m4-3w8q"}],"products":null,"published":"2025-05-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to WordPress sites using the Auth0 plugin.","url":"https://insights.sbomify.com/GHSA-2f4r-34m4-3w8q/"}