{"answers":{"affected":"3 open source packages ship an affected version, including nftnl.","exploited":"There is no known exploitation of GHSA-2fjw-whxm-9v4q in the wild and no public exploit code.","fix":"Upgrade nftnl to 0.9.0 or later.","what":"GHSA-2fjw-whxm-9v4q is a memory corruption vulnerability in nftnl, published on 18 Oct 2025."},"fix_prompt":"Check this codebase for GHSA-2fjw-whxm-9v4q and fix it if it is affected.\n\nWhat it is: GHSA-2fjw-whxm-9v4q is a memory corruption vulnerability in nftnl, published on 18 Oct 2025. \nExploitation: There is no known exploitation of GHSA-2fjw-whxm-9v4q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nftnl (crates.io): affected all versions; fixed in 0.9.0\n- nftnl (crates.io): affected all versions; fixed in 0.9.0\n- nftnl (crates.io): affected from 0.0.0-0; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2fjw-whxm-9v4q/ (Markdown: https://insights.sbomify.com/GHSA-2fjw-whxm-9v4q/index.md)","id":"GHSA-2fjw-whxm-9v4q","markdown":"https://insights.sbomify.com/GHSA-2fjw-whxm-9v4q/index.md","name":"GHSA-2fjw-whxm-9v4q","record":{"aliases":["RUSTSEC-2025-0126"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"unknown","non_default_config":false,"product_category":"Rust nftnl wrapper","requires_auth":"none","summary":"A heap-buffer-overflow in the nftnl-rs library allows attackers to cause out-of-bounds writes and potential code execution via malformed page sizes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A heap-buffer-overflow vulnerability exists in the Rust wrapper for libnftnl, triggered via the nftnl::Batch::with_page_size constructor. When a small or malformed page size is provided, the underlying C code allocates an insufficient buffer, leading to out-of-bounds writes during batch initialization.\n\nThe flaw was fixed in commit 94a286f by adding an overflow check:\n```Rust\nbatch_page_size\n    .checked_add(crate::nft_nlmsg_maxsize())\n    .expect(\"batch_page_size is too large and would overflow\");\n```\n\n## Mitigation\n\nUpgrade to version `0.9.0` or later, which aborts instead.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Heap-buffer-overflow in nftnl::Batch::with_page_size (nftnl-rs)","id":"GHSA-2fjw-whxm-9v4q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"nftnl","purl":null,"source":"GHSA-2fjw-whxm-9v4q"},{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"nftnl","purl":"pkg:cargo/nftnl","source":"GHSA-2fjw-whxm-9v4q"},{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"nftnl","purl":"pkg:cargo/nftnl","source":"RUSTSEC-2025-0126"}],"products":null,"published":"2025-10-18","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A heap-buffer-overflow in the nftnl-rs library allows attackers to cause out-of-bounds writes and potential code execution via malformed page sizes.","url":"https://insights.sbomify.com/GHSA-2fjw-whxm-9v4q/"}