{"answers":{"affected":"2 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend.","exploited":"There is no known exploitation of GHSA-2g8g-63j4-9w3r in the wild and no public exploit code.","fix":"Upgrade @backstage/plugin-scaffolder-backend to 0.15.14 or later.","what":"GHSA-2g8g-63j4-9w3r is a code injection vulnerability in @backstage/plugin-scaffolder-backend, published on 1 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2g8g-63j4-9w3r and fix it if it is affected.\n\nWhat it is: GHSA-2g8g-63j4-9w3r is a code injection vulnerability in @backstage/plugin-scaffolder-backend, published on 1 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2g8g-63j4-9w3r in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 0.15.14\n- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 0.15.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2g8g-63j4-9w3r/ (Markdown: https://insights.sbomify.com/GHSA-2g8g-63j4-9w3r/index.md)","id":"GHSA-2g8g-63j4-9w3r","markdown":"https://insights.sbomify.com/GHSA-2g8g-63j4-9w3r/index.md","name":"GHSA-2g8g-63j4-9w3r","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Backstage scaffolder plugin","requires_auth":"low_privilege","summary":"An attacker with write access to scaffolder templates can achieve remote code execution on the backend by injecting malicious code into template definitions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The templating library used by the scaffolder backend assumes that templates are trusted which is an undesired property of the scaffolder-backend. This has now been mitigated by sandboxing the template code execution.\n\n### Impact\nA malicious actor with write access to a registered scaffolder template could manipulate the template in a way that allows for remote code execution on the scaffolder-backend instance. This was only exploitable in the template yaml definition itself and not by user input data.\n\n### Patches\nThis is vulnerability is patched in version `0.15.14` of `@backstage/plugin-scaffolder-backend`.\n\n### For more information\nIf you have any questions or comments about this advisory:\n\n* Open an issue in the [Backstage repository](https://github.com/backstage/backstage)\n* Visit our chat, linked to in [Backstage README](https://github.com/backstage/backstage)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"RCE vulnerability affecting v1beta3 templates in @backstage/plugin-scaffolder-backend","id":"GHSA-2g8g-63j4-9w3r","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.15.14"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-scaffolder-backend","purl":null,"source":"GHSA-2g8g-63j4-9w3r"},{"ecosystem":"npm","fixed":["0.15.14"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-scaffolder-backend","purl":"pkg:npm/%40backstage/plugin-scaffolder-backend","source":"GHSA-2g8g-63j4-9w3r"}],"products":null,"published":"2021-12-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker with write access to scaffolder templates can achieve remote code execution on the backend by injecting malicious code into template definitions.","url":"https://insights.sbomify.com/GHSA-2g8g-63j4-9w3r/"}