{"answers":{"affected":"2 open source packages ship an affected version, including gregwar/rst.","exploited":"There is no known exploitation of GHSA-2gq2-m628-33xp in the wild and no public exploit code.","fix":"Upgrade gregwar/rst to 1.0.3 or later.","what":"GHSA-2gq2-m628-33xp is a path traversal vulnerability in gregwar/rst, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2gq2-m628-33xp and fix it if it is affected.\n\nWhat it is: GHSA-2gq2-m628-33xp is a path traversal vulnerability in gregwar/rst, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2gq2-m628-33xp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gregwar/rst (Packagist): affected all versions; fixed in 1.0.3\n- gregwar/rst (Packagist): affected all versions; fixed in 1.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2gq2-m628-33xp/ (Markdown: https://insights.sbomify.com/GHSA-2gq2-m628-33xp/index.md)","id":"GHSA-2gq2-m628-33xp","markdown":"https://insights.sbomify.com/GHSA-2gq2-m628-33xp/index.md","name":"GHSA-2gq2-m628-33xp","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP RST library","requires_auth":"none","summary":"An attacker can exploit inadequate input validation in the gregwar/rst library to include arbitrary files and read sensitive server data.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A Local File Inclusion (LFI) vulnerability has been discovered in the gregwar/rst library, potentially exposing sensitive files on the server to unauthorized users. The issue arises from inadequate input validation, allowing an attacker to manipulate file paths and include arbitrary files.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"gregwar/rst Local File Inclusion Vulnerability","id":"GHSA-2gq2-m628-33xp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"gregwar/rst","purl":null,"source":"GHSA-2gq2-m628-33xp"},{"ecosystem":"Packagist","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"gregwar/rst","purl":"pkg:composer/gregwar/rst","source":"GHSA-2gq2-m628-33xp"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can exploit inadequate input validation in the gregwar/rst library to include arbitrary files and read sensitive server data.","url":"https://insights.sbomify.com/GHSA-2gq2-m628-33xp/"}