{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework1.","exploited":"There is no known exploitation of GHSA-2jx7-xg83-j2m7 in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework1 to 1.11.13 or later.","what":"GHSA-2jx7-xg83-j2m7 is a denial of service vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2jx7-xg83-j2m7 and fix it if it is affected.\n\nWhat it is: GHSA-2jx7-xg83-j2m7 is a denial of service vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2jx7-xg83-j2m7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework1 (Packagist): affected from 1.0.0; fixed in 1.11.13\n- zendframework/zendframework1 (Packagist): affected from 1.0.0; fixed in 1.11.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2jx7-xg83-j2m7/ (Markdown: https://insights.sbomify.com/GHSA-2jx7-xg83-j2m7/index.md)","id":"GHSA-2jx7-xg83-j2m7","markdown":"https://insights.sbomify.com/GHSA-2jx7-xg83-j2m7/index.md","name":"GHSA-2jx7-xg83-j2m7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP framework","requires_auth":"none","summary":"Attackers can cause Denial of Service in Zend Framework components via XML Entity Expansion attacks, affecting applications processing untrusted XML.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"`Zend_Dom`, `Zend_Feed`, `Zend_Soap`, and `Zend_XmlRpc` are vulnerable to XML Entity Expansion (XEE) vectors, leading to Denial of Service vectors. XEE attacks occur when the XML DOCTYPE declaration includes XML entity definitions that contain either recursive or circular references; this leads to CPU and memory consumption, making Denial of Service exploits trivial to implement.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Zendframework Denial of Service vector via XEE injection","id":"GHSA-2jx7-xg83-j2m7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.11.13"],"introduced":["1.0.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-2jx7-xg83-j2m7"},{"ecosystem":"Packagist","fixed":["1.11.13"],"introduced":["1.0.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-2jx7-xg83-j2m7"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause Denial of Service in Zend Framework components via XML Entity Expansion attacks, affecting applications processing untrusted XML.","url":"https://insights.sbomify.com/GHSA-2jx7-xg83-j2m7/"}