{"answers":{"affected":"2 open source packages ship an affected version, including cartalyst/sentry.","exploited":"There is no known exploitation of GHSA-2m5g-8xpw-42vp in the wild and no public exploit code.","fix":"Upgrade cartalyst/sentry to 2.1.7 or later.","what":"GHSA-2m5g-8xpw-42vp is an authentication bypass vulnerability in cartalyst/sentry, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2m5g-8xpw-42vp and fix it if it is affected.\n\nWhat it is: GHSA-2m5g-8xpw-42vp is an authentication bypass vulnerability in cartalyst/sentry, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2m5g-8xpw-42vp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cartalyst/sentry (Packagist): affected all versions; fixed in 2.1.7\n- cartalyst/sentry (Packagist): affected all versions; fixed in 2.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2m5g-8xpw-42vp/ (Markdown: https://insights.sbomify.com/GHSA-2m5g-8xpw-42vp/index.md)","id":"GHSA-2m5g-8xpw-42vp","markdown":"https://insights.sbomify.com/GHSA-2m5g-8xpw-42vp/index.md","name":"GHSA-2m5g-8xpw-42vp","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Conference submission system","requires_auth":"none","summary":"Attackers can take over OpenCFP user accounts by exploiting null password reset codes in the Sentry authentication framework.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"OpenCFP, an open-source conference talk submission system written in PHP, contains a security vulnerability in its third-party authentication framework, Sentry, developed by Cartalyst. The vulnerability stems from how Sentry handles password reset checks. Users lacking a password reset token stored in the database default to having NULL in the reset_password_code column. Exploiting this flaw could allow unauthorized manipulation of any OpenCFP user's password, particularly those without an unused password reset token. Although successful login still requires correlating the numeric user ID with an email address, the identification of likely organizers (users 1-5) may facilitate this process.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenCFP Framework (Sentry) Account takeover via null password reset codes","id":"GHSA-2m5g-8xpw-42vp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.1.7"],"introduced":["0"],"last_affected":[],"package":"cartalyst/sentry","purl":null,"source":"GHSA-2m5g-8xpw-42vp"},{"ecosystem":"Packagist","fixed":["2.1.7"],"introduced":["0"],"last_affected":[],"package":"cartalyst/sentry","purl":"pkg:composer/cartalyst/sentry","source":"GHSA-2m5g-8xpw-42vp"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can take over OpenCFP user accounts by exploiting null password reset codes in the Sentry authentication framework.","url":"https://insights.sbomify.com/GHSA-2m5g-8xpw-42vp/"}