# GHSA-2mf3-mr2r-r4vf: @rhinostone/swig: arbitrary local file read via include/extends path traversal

> Attackers can read arbitrary local files by manipulating template include paths, exposing sensitive data like credentials and configuration.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026

## What is GHSA-2mf3-mr2r-r4vf?

GHSA-2mf3-mr2r-r4vf is a path traversal vulnerability in @rhinostone/swig, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Overview

`@rhinostone/swig` is a maintained fork of the abandoned `swig` template engine and inherited the directory-traversal vulnerability tracked upstream as CVE-2023-25345 / GHSA-2rq5-699j-x7p6. The `{% include %}`, `{% extends %}`, and `{% import %}` tags resolve their target path through the filesystem loader without confining the result to the configured template root. A path that traverses upward (`../`) escapes the root and reads an arbitrary file from the host filesystem, whose contents are emitted into the rendered output.

### Attack scenario

The dangerous case does **not** require the attacker to control template source — only template **data** (the `locals` passed at render time). An application that renders a trusted template whose include / extends path is variable-driven is exposed:

```js
// application code — a configured filesystem loader with a basepath
swig.renderFile('page.html', { partial: req.query.partial });
```

```
{# page.html — trusted template #}
{% include partial %}
```

Setting `?partial=../../../../etc/passwd` makes the loader resolve and read that file, and its contents are rendered into the response. A literal in trusted source is equally affected: `{% include "../../../etc/passwd" %}`.

### Impact

Arbitrary local file disclosure (confidentiality). An attacker able to influence an include / extends / import path — directly, or via untrusted `locals` — can read files outside the template directory: application configuration, credentials, source code, `/etc/passwd`, and so on. There is no integrity or availability impact.

### Affected & patched

Every published version up to and including `2.7.0` is affected — `@rhinostone/swig`, and the shared `@rhinostone/swig-core` loader, hence `@rhinostone/swig-twig`, `@rhinostone/swig-jinja2`, and `@rhinostone/swig-django` as well.

Fixed in **`2.7.1`**: the filesystem loader now rejects any `include` / `extends` / `import` path that resolves outside the configured `basepath` root, including paths supplied through an untrusted runtime variable. A new `allowOutsideRoot` loader option is available for the rare case of intentionally reading files from outside the root.

**Upgrade to `2.7.2` or later:** `2.7.1` fixed the vulnerability but introduced a regression — a *relative* `basepath` wrongly rejected every in-root template path. `2.7.2` resolves the `basepath` to an absolute path before the check and restores correct in-root resolution.

### Workarounds

- Upgrade to `2.7.2` (or later).
- If you cannot upgrade immediately: configure the filesystem loader with an explicit `basepath`, and never pass untrusted data into an `{% include %}` / `{% extends %}` / `{% import %}` path.

### References

- GHSA-2rq5-699j-x7p6 — https://github.com/advisories/GHSA-2rq5-699j-x7p6
- CVE-2023-25345 (NVD) — https://nvd.nist.gov/vuln/detail/CVE-2023-25345
- Upstream issue (swig-templates) — https://github.com/node-swig/swig-templates/issues/88
- Fix commit — https://github.com/gina-io/swig/commit/381bdc305e0b10e45368d56324328b9b4f7017fc

## Which versions are affected by GHSA-2mf3-mr2r-r4vf?

10 open source packages ship an affected version, including @rhinostone/swig, @rhinostone/swig-core and @rhinostone/swig-django.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@rhinostone/swig` | npm | All versions | 2.7.1 |
| `@rhinostone/swig` | npm | All versions | 2.7.1 |
| `@rhinostone/swig-core` | npm | All versions | 2.7.1 |
| `@rhinostone/swig-core` | npm | All versions | 2.7.1 |
| `@rhinostone/swig-django` | npm | All versions | 2.7.1 |
| `@rhinostone/swig-django` | npm | All versions | 2.7.1 |
| `@rhinostone/swig-jinja2` | npm | All versions | 2.7.1 |
| `@rhinostone/swig-jinja2` | npm | All versions | 2.7.1 |
| `@rhinostone/swig-twig` | npm | All versions | 2.7.1 |
| `@rhinostone/swig-twig` | npm | All versions | 2.7.1 |

## How do I fix GHSA-2mf3-mr2r-r4vf?

Upgrade @rhinostone/swig to 2.7.1 or later.

## Is GHSA-2mf3-mr2r-r4vf being exploited?

There is no known exploitation of GHSA-2mf3-mr2r-r4vf in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-2mf3-mr2r-r4vf and fix it if it is affected.

What it is: GHSA-2mf3-mr2r-r4vf is a path traversal vulnerability in @rhinostone/swig, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-2mf3-mr2r-r4vf in the wild and no public exploit code.

Affected packages and fixed versions:
- @rhinostone/swig (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig-core (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig-core (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig-django (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig-django (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig-jinja2 (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig-jinja2 (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig-twig (npm): affected all versions; fixed in 2.7.1
- @rhinostone/swig-twig (npm): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-2mf3-mr2r-r4vf/ (Markdown: https://insights.sbomify.com/GHSA-2mf3-mr2r-r4vf/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-2mf3-mr2r-r4vf

---
From sbomify Insights: https://insights.sbomify.com/GHSA-2mf3-mr2r-r4vf/
Summaries are generated and may contain mistakes; the official description above is the record.
