# GHSA-2mhw-8qcg-gr96: skia-python vendors vulnerable libfreetype because of pinned cibuildwheel version

> skia-python Linux wheels contain a vulnerable libfreetype due to build environment pinning, allowing potential code execution via crafted fonts.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2026

## What is GHSA-2mhw-8qcg-gr96?

GHSA-2mhw-8qcg-gr96 is a vulnerability in skia-python, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

### Impact

The Linux wheels for skia-python vendor a vulnerable version of
libfreetype that is affected by CVE-2025-27363 [1].

The root cause is a chain of unfortunate events:

1. skia-python builds wheels using pinned pypa/cibuildwheel@2.21.3 [2]

2. cibuildwheel 2.21.3 in turn pins manylinux container images [3]

3. In these images, version 2.9.1-9.el8 of RedHat package freetype is
*preinstalled*. This package version is vulnerable and has since been
patched in 2.9.1-10.

4. During the skia-python Linux build, libfreetype is vendored from the
system, resulting in skia-python.libs/libfreetype-29a7443c.so.6.16.1

[ To find the provenance of your vendored libfreetype, we extracted the
8-character hash of the original binary file that is added during the
build process (29a7443c), and matched it against our database of hashes
all historic Red Hat, Debian and Ubuntu releases of freetype. ]

5. Because freetype is only a *transitive* dependency of the packages
explicitly installed by the build script [4], it is not upgraded to the
patched version [4].

5. As a result, the published wheels embed a vulnerable libfreetype,
even though patched packages are available upstream.

This appears to be a broader manylinux ecosystem issue. The base images
do not enforce that `yum update` runs on container start, so
preinstalled libraries may remain vulnerable indefinitely.

### Patches

> In the case of skia-python, the solution is to explicitly install freetype in the build process and rebuild the wheels.

The original report was suggesting the above, but in the current `build_Linux.sh` script, the patched `freetype-devel` version 2.9.1-10 gets installed as a dependency. It's just that we need to rebuild the wheel for a new release.

### Workarounds

Users must upgrade the wheel package after release.

### References

1. https://nvd.nist.gov/vuln/detail/CVE-2025-27363
2. https://github.com/kyamagu/skia-python/blob/9ffb045811f9b5508e152302d5b81aadca6edd8d/.github/workflows/ci.yml#L38
3. https://github.com/pypa/cibuildwheel/blob/v2.21.3/cibuildwheel/resources/pinned_docker_images.cfg
4. https://github.com/kyamagu/skia-python/blob/9ffb045811f9b5508e152302d5b81aadca6edd8d/scripts/build_Linux.sh#L6

## Which versions are affected by GHSA-2mhw-8qcg-gr96?

4 open source packages ship an affected version, including skia-python.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `skia-python` | PyPI | All versions | None |
| `skia-python` | PyPI | All versions | None |
| `skia-python` | PyPI | All versions | 144.0.post1 |
| `skia-python` | PyPI | All versions | 144.0.post1 |

## How do I fix GHSA-2mhw-8qcg-gr96?

Upgrade skia-python to 144.0.post1 or later.

## Is GHSA-2mhw-8qcg-gr96 being exploited?

There is no known exploitation of GHSA-2mhw-8qcg-gr96 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-2mhw-8qcg-gr96 and fix it if it is affected.

What it is: GHSA-2mhw-8qcg-gr96 is a vulnerability in skia-python, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-2mhw-8qcg-gr96 in the wild and no public exploit code.

Affected packages and fixed versions:
- skia-python (PyPI): affected all versions; no fix listed
- skia-python (PyPI): affected all versions; no fix listed
- skia-python (PyPI): affected all versions; fixed in 144.0.post1
- skia-python (PyPI): affected all versions; fixed in 144.0.post1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-2mhw-8qcg-gr96/ (Markdown: https://insights.sbomify.com/GHSA-2mhw-8qcg-gr96/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-2mhw-8qcg-gr96

---
From sbomify Insights: https://insights.sbomify.com/GHSA-2mhw-8qcg-gr96/
Summaries are generated and may contain mistakes; the official description above is the record.
