GHSA-2p4f-vc9q-r5vp Typo3 Arbitrary file upload and XML External Entity processing
Arbitrary file upload in Flow framework allows remote code execution if server executes uploaded scripts, requiring specific application configuration.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-2p4f-vc9q-r5vp?
GHSA-2p4f-vc9q-r5vp is a vulnerability in typo3/flow, published on 5 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
It has been discovered that Flow 3.0.0 allows arbitrary file uploads, inlcuding server-side scripts, posing the risk of attacks. If those scripts are executed by the server when accessed through their public URL, anything not blocked through other means is possible (information disclosure, placement of backdoors, data removal, …).
Note: The upload of files is only possible if the application built on Flow provides means to do so, and whether or not the upload of files poses a risk is dependent on the system setup. If uploaded script files are not executed by the server, there is no risk. In versions prior to 3.0.0 the upload of files with the extension php was blocked.
In Flow 2.3.0 to 2.3.6 a potential XML External Entity processing vulnerability has been discovered in the MediaTypeConverter.
Which versions are affected by GHSA-2p4f-vc9q-r5vp?
4 open source packages ship an affected version, including typo3/flow.
| Package | Affected | Fixed in |
|---|---|---|
typo3/flow Packagist | From 2.3.0 | 2.3.7 |
typo3/flow Packagist | From 2.3.0 | 2.3.7 |
typo3/flow Packagist | From 3.0.0 | 3.0.1 |
typo3/flow Packagist | From 3.0.0 | 3.0.1 |
How do I fix GHSA-2p4f-vc9q-r5vp?
Upgrade typo3/flow to a fixed version for your release line: 2.3.7 or 3.0.1.
Is GHSA-2p4f-vc9q-r5vp being exploited?
There is no known exploitation of GHSA-2p4f-vc9q-r5vp in the wild and no public exploit code.