# GHSA-2p4f-vc9q-r5vp: Typo3 Arbitrary file upload and XML External Entity processing

> Arbitrary file upload in Flow framework allows remote code execution if server executes uploaded scripts, requiring specific application configuration.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2024

## What is GHSA-2p4f-vc9q-r5vp?

GHSA-2p4f-vc9q-r5vp is a vulnerability in typo3/flow, published on 5 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

It has been discovered that Flow 3.0.0 allows arbitrary file uploads, inlcuding server-side scripts, posing the risk of attacks. If those scripts are executed by the server when accessed through their public URL, anything not blocked through other means is possible (information disclosure, placement of backdoors, data removal, …).

Note: The upload of files is only possible if the application built on Flow provides means to do so, and whether or not the upload of files poses a risk is dependent on the system setup. If uploaded script files are not executed by the server, there is no risk. In versions prior to 3.0.0 the upload of files with the extension php was blocked.

In Flow 2.3.0 to 2.3.6 a potential XML External Entity processing vulnerability has been discovered in the MediaTypeConverter.

## Which versions are affected by GHSA-2p4f-vc9q-r5vp?

4 open source packages ship an affected version, including typo3/flow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/flow` | Packagist | From 2.3.0 | 2.3.7 |
| `typo3/flow` | Packagist | From 2.3.0 | 2.3.7 |
| `typo3/flow` | Packagist | From 3.0.0 | 3.0.1 |
| `typo3/flow` | Packagist | From 3.0.0 | 3.0.1 |

## How do I fix GHSA-2p4f-vc9q-r5vp?

Upgrade typo3/flow to a fixed version for your release line: 2.3.7 or 3.0.1.

## Is GHSA-2p4f-vc9q-r5vp being exploited?

There is no known exploitation of GHSA-2p4f-vc9q-r5vp in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-2p4f-vc9q-r5vp and fix it if it is affected.

What it is: GHSA-2p4f-vc9q-r5vp is a vulnerability in typo3/flow, published on 5 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-2p4f-vc9q-r5vp in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/flow (Packagist): affected from 2.3.0; fixed in 2.3.7
- typo3/flow (Packagist): affected from 2.3.0; fixed in 2.3.7
- typo3/flow (Packagist): affected from 3.0.0; fixed in 3.0.1
- typo3/flow (Packagist): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-2p4f-vc9q-r5vp/ (Markdown: https://insights.sbomify.com/GHSA-2p4f-vc9q-r5vp/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-2p4f-vc9q-r5vp

---
From sbomify Insights: https://insights.sbomify.com/GHSA-2p4f-vc9q-r5vp/
Summaries are generated and may contain mistakes; the official description above is the record.
