GHSA-2p62-c4rm-mr72 Malicious Package in another-date-picker

Not scored Published

A malicious npm package version steals credit card and password data from web forms, requiring developers to upgrade to a safe version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is GHSA-2p62-c4rm-mr72?

GHSA-2p62-c4rm-mr72 is a vulnerability in another-date-picker, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Version 2.0.43 of another-date-picker contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl=

Recommendation

If version 2.0.43 of this module is found installed you will want to replace it with a version before or after 2.0.43. In addition to replacing the installed module, you will also want to evaluate your application to determine whether or not user data was compromised.

Which versions are affected by GHSA-2p62-c4rm-mr72?

2 open source packages ship an affected version, including another-date-picker.

PackageAffectedFixed in
another-date-picker npmFrom 2.0.432.0.45
another-date-picker npmFrom 2.0.432.0.45

How do I fix GHSA-2p62-c4rm-mr72?

Upgrade another-date-picker to 2.0.45 or later.

Is GHSA-2p62-c4rm-mr72 being exploited?

There is no known exploitation of GHSA-2p62-c4rm-mr72 in the wild and no public exploit code.

Sources

Is GHSA-2p62-c4rm-mr72 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free