{"answers":{"affected":"2 open source packages ship an affected version, including js-yaml.","exploited":"There is no known exploitation of GHSA-2pr6-76vf-7546 in the wild and no public exploit code.","fix":"Upgrade js-yaml to 3.13.0 or later.","what":"GHSA-2pr6-76vf-7546 is a denial of service vulnerability in js-yaml, published on 5 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2pr6-76vf-7546 and fix it if it is affected.\n\nWhat it is: GHSA-2pr6-76vf-7546 is a denial of service vulnerability in js-yaml, published on 5 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2pr6-76vf-7546 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- js-yaml (npm): affected all versions; fixed in 3.13.0\n- js-yaml (npm): affected all versions; fixed in 3.13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2pr6-76vf-7546/ (Markdown: https://insights.sbomify.com/GHSA-2pr6-76vf-7546/index.md)","id":"GHSA-2pr6-76vf-7546","markdown":"https://insights.sbomify.com/GHSA-2pr6-76vf-7546/index.md","name":"GHSA-2pr6-76vf-7546","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript YAML parser","requires_auth":"none","summary":"An attacker can cause a denial of service by providing a crafted YAML file to applications using the vulnerable js-yaml library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `js-yaml` prior to 3.13.0 are vulnerable to Denial of Service. By parsing a carefully-crafted YAML file, the node process stalls and may exhaust system resources leading to a Denial of Service.\n\n## Recommendation\n\nUpgrade to version 3.13.0.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in js-yaml","id":"GHSA-2pr6-76vf-7546","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.13.0"],"introduced":["0"],"last_affected":[],"package":"js-yaml","purl":null,"source":"GHSA-2pr6-76vf-7546"},{"ecosystem":"npm","fixed":["3.13.0"],"introduced":["0"],"last_affected":[],"package":"js-yaml","purl":"pkg:npm/js-yaml","source":"GHSA-2pr6-76vf-7546"}],"products":null,"published":"2019-06-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service by providing a crafted YAML file to applications using the vulnerable js-yaml library.","url":"https://insights.sbomify.com/GHSA-2pr6-76vf-7546/"}