{"answers":{"affected":"2 open source packages ship an affected version, including org.opensearch.plugin:opensearch-security.","exploited":"There is no known exploitation of GHSA-2rjv-cv85-xhgm in the wild and no public exploit code.","fix":"Upgrade org.opensearch.plugin:opensearch-security to 2.19.3.0 or later.","what":"GHSA-2rjv-cv85-xhgm is a missing authorization vulnerability in org.opensearch.plugin:opensearch-security, published on 1 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2rjv-cv85-xhgm and fix it if it is affected.\n\nWhat it is: GHSA-2rjv-cv85-xhgm is a missing authorization vulnerability in org.opensearch.plugin:opensearch-security, published on 1 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2rjv-cv85-xhgm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opensearch.plugin:opensearch-security (Maven): affected all versions; fixed in 2.19.3.0\n- org.opensearch.plugin:opensearch-security (Maven): affected all versions; fixed in 2.19.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2rjv-cv85-xhgm/ (Markdown: https://insights.sbomify.com/GHSA-2rjv-cv85-xhgm/index.md)","id":"GHSA-2rjv-cv85-xhgm","markdown":"https://insights.sbomify.com/GHSA-2rjv-cv85-xhgm/index.md","name":"GHSA-2rjv-cv85-xhgm","record":{"aliases":[],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenSearch search engine","requires_auth":"low_privilege","summary":"Attackers with low privileges can bypass Field Level Security to read protected nested data in OpenSearch if specific exclusion rules are used.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nOpenSearch versions 2.19.2 and earlier improperly apply Field Level Security (FLS) rules on fields which are not at the top level of the source document tree (i.e., which are members of a JSON object). \n\nIf an FLS exclusion rule (like `~object`) is applied to an object valued attribute in a source document, the object is properly removed from the `_source` document in search and get results. However, any member attribute of that object remains available to search queries. This allows to reconstruct the original field contents using range queries. \n\n### Patches\n\nThe issue has been resolved in OpenSearch 3.0.0 and OpenSearch 2.19.3.\n\n### Workarounds\n\nIf FLS exclusion rules are used for object valued attributes  (like `~object`), add an additional exclusion rule for the members of the object  (like `~object.*`).","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenSearch unauthorized data access on fields protected by field level security if field is a member of an object","id":"GHSA-2rjv-cv85-xhgm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.19.3.0"],"introduced":["0"],"last_affected":[],"package":"org.opensearch.plugin:opensearch-security","purl":null,"source":"GHSA-2rjv-cv85-xhgm"},{"ecosystem":"Maven","fixed":["2.19.3.0"],"introduced":["0"],"last_affected":[],"package":"org.opensearch.plugin:opensearch-security","purl":"pkg:maven/org.opensearch.plugin/opensearch-security","source":"GHSA-2rjv-cv85-xhgm"}],"products":null,"published":"2025-08-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers with low privileges can bypass Field Level Security to read protected nested data in OpenSearch if specific exclusion rules are used.","url":"https://insights.sbomify.com/GHSA-2rjv-cv85-xhgm/"}