{"answers":{"affected":"3 open source packages ship an affected version, including anstream.","exploited":"There is no known exploitation of GHSA-2rxc-gjrp-vjhx in the wild and no public exploit code.","fix":"Upgrade anstream to 0.6.8 or later.","what":"GHSA-2rxc-gjrp-vjhx is a memory corruption vulnerability in anstream, published on 8 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2rxc-gjrp-vjhx and fix it if it is affected.\n\nWhat it is: GHSA-2rxc-gjrp-vjhx is a memory corruption vulnerability in anstream, published on 8 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2rxc-gjrp-vjhx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- anstream (crates.io): affected all versions; fixed in 0.6.8\n- anstream (crates.io): affected all versions; fixed in 0.6.8\n- anstream (crates.io): affected from 0.0.0-0; fixed in 0.6.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2rxc-gjrp-vjhx/ (Markdown: https://insights.sbomify.com/GHSA-2rxc-gjrp-vjhx/index.md)","id":"GHSA-2rxc-gjrp-vjhx","markdown":"https://insights.sbomify.com/GHSA-2rxc-gjrp-vjhx/index.md","name":"GHSA-2rxc-gjrp-vjhx","record":{"aliases":["RUSTSEC-2024-0404"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust anstream library","requires_auth":"none","summary":"An unsoundness in the anstream library allows attackers to cause memory corruption or crashes by providing specific UTF-8 strings, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"When given a valid UTF8 string \"ö\\x1b😀\", the function in\ncrates/anstream/src/adapter/strip.rs will be confused. The UTF8\nbytes are \\xc3\\xb6 then \\x1b then \\xf0\\x9f\\x98\\x80.\n\nWhen looping over \"non-printable bytes\" \\x1b\\xf0 will be\nconsidered as some non-printable sequence.\n\nThis will produce a broken str from the incorrectly segmented\nbytes via str::from_utf8_unchecked, and that should never happen.\n\nFull credit goes to [@Ralith](https://github.com/Ralith) who reviewed this code and\nasked [@burakemir](https://github.com/burakemir) to follow up.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Unsoundness in anstream","id":"GHSA-2rxc-gjrp-vjhx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.6.8"],"introduced":["0"],"last_affected":[],"package":"anstream","purl":null,"source":"GHSA-2rxc-gjrp-vjhx"},{"ecosystem":"crates.io","fixed":["0.6.8"],"introduced":["0"],"last_affected":[],"package":"anstream","purl":"pkg:cargo/anstream","source":"GHSA-2rxc-gjrp-vjhx"},{"ecosystem":"crates.io","fixed":["0.6.8"],"introduced":["0.0.0-0"],"last_affected":[],"package":"anstream","purl":"pkg:cargo/anstream","source":"RUSTSEC-2024-0404"}],"products":null,"published":"2024-09-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An unsoundness in the anstream library allows attackers to cause memory corruption or crashes by providing specific UTF-8 strings, potentially leading to code execution.","url":"https://insights.sbomify.com/GHSA-2rxc-gjrp-vjhx/"}