{"answers":{"affected":"2 open source packages ship an affected version, including @soketi/soketi.","exploited":"There is no known exploitation of GHSA-2w8g-m5j8-7m87 in the wild and no public exploit code.","fix":"Upgrade @soketi/soketi to 0.26.1 or later.","what":"GHSA-2w8g-m5j8-7m87 is a denial of service vulnerability in @soketi/soketi, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2w8g-m5j8-7m87 and fix it if it is affected.\n\nWhat it is: GHSA-2w8g-m5j8-7m87 is a denial of service vulnerability in @soketi/soketi, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2w8g-m5j8-7m87 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @soketi/soketi (npm): affected all versions; fixed in 0.26.1\n- @soketi/soketi (npm): affected all versions; fixed in 0.26.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2w8g-m5j8-7m87/ (Markdown: https://insights.sbomify.com/GHSA-2w8g-m5j8-7m87/index.md)","id":"GHSA-2w8g-m5j8-7m87","markdown":"https://insights.sbomify.com/GHSA-2w8g-m5j8-7m87/index.md","name":"GHSA-2w8g-m5j8-7m87","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js colors library","requires_auth":"none","summary":"The colors library generates excessive output that crashes servers, requiring users to upgrade to the patched version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n_What kind of vulnerability is it? Who is impacted?_\n\n[`colors`](https://npmjs.com/package/colors) package caused zalgo-like output (see https://github.com/soketi/soketi/issues/276, https://github.com/Marak/colors.js/issues/289), breaking the servers.\n\n**Only NPM users that recently upgraded or installed the NPM package are affected.**\n\nDocker users seem to not be affected as the dependencies were bundled at the time of the build, which were tested.\n\n### Patches\n_Has the problem been patched? What versions should users upgrade to?_\n\nLatest patch. `0.26.1` to be exact at the time of writing.\n\n### Workarounds\n_Is there a way for users to fix or remediate the vulnerability without upgrading?_\n\nYou cannot get around this as it's related to dependencies.\n\n### References\n_Are there any links users can visit to find out more?_\n\n- https://github.com/Marak/colors.js/issues/289\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [the issues board](https://github.com/soketi/soketi/issues)\n* Email us at [alex@renoki.org](mailto:alex@renoki.org)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Zalgo-like output that crashes the server","id":"GHSA-2w8g-m5j8-7m87","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.26.1"],"introduced":["0"],"last_affected":[],"package":"@soketi/soketi","purl":null,"source":"GHSA-2w8g-m5j8-7m87"},{"ecosystem":"npm","fixed":["0.26.1"],"introduced":["0"],"last_affected":[],"package":"@soketi/soketi","purl":"pkg:npm/%40soketi/soketi","source":"GHSA-2w8g-m5j8-7m87"}],"products":null,"published":"2022-01-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The colors library generates excessive output that crashes servers, requiring users to upgrade to the patched version.","url":"https://insights.sbomify.com/GHSA-2w8g-m5j8-7m87/"}