# GHSA-2w9p-xxqr-h253: eZ Platform Object Injection in SiteAccessMatchListener

> An object injection vulnerability in eZ Platform allows remote attackers to execute arbitrary code without authentication.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2024

## What is GHSA-2w9p-xxqr-h253?

GHSA-2w9p-xxqr-h253 is an unsafe deserialization vulnerability in ezsystems/ezplatform-kernel, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This Security Advisory is about an object injection vulnerability in the SiteAccessMatchListener of eZ Platform, which could lead to remote code execution (RCE), a very serious threat. All sites may be affected.

Update: There are bugs introduced by this fix, particularly but not limited to compound siteaccess matchers. These have been fixed in ezsystems/ezplatform-kernel v1.0.3, and in ezsystems/ezpublish-kernel v7.5.8, v6.13.6.4, and v5.4.15.

## Which versions are affected by GHSA-2w9p-xxqr-h253?

2 open source packages ship an affected version, including ezsystems/ezplatform-kernel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezplatform-kernel` | Packagist | From 1.0.0 | 1.0.3 |
| `ezsystems/ezplatform-kernel` | Packagist | From 1.0.0 | 1.0.3 |

## How do I fix GHSA-2w9p-xxqr-h253?

Upgrade ezsystems/ezplatform-kernel to 1.0.3 or later.

## Is GHSA-2w9p-xxqr-h253 being exploited?

There is no known exploitation of GHSA-2w9p-xxqr-h253 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-2w9p-xxqr-h253 and fix it if it is affected.

What it is: GHSA-2w9p-xxqr-h253 is an unsafe deserialization vulnerability in ezsystems/ezplatform-kernel, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-2w9p-xxqr-h253 in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezplatform-kernel (Packagist): affected from 1.0.0; fixed in 1.0.3
- ezsystems/ezplatform-kernel (Packagist): affected from 1.0.0; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-2w9p-xxqr-h253/ (Markdown: https://insights.sbomify.com/GHSA-2w9p-xxqr-h253/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-2w9p-xxqr-h253

---
From sbomify Insights: https://insights.sbomify.com/GHSA-2w9p-xxqr-h253/
Summaries are generated and may contain mistakes; the official description above is the record.
