{"answers":{"affected":"2 open source packages ship an affected version, including ng-ui-library.","exploited":"There is no known exploitation of GHSA-2xw5-3767-qxvm in the wild and no public exploit code.","fix":"Upgrade ng-ui-library to 1.0.990 or later.","what":"GHSA-2xw5-3767-qxvm is a vulnerability in ng-ui-library, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-2xw5-3767-qxvm and fix it if it is affected.\n\nWhat it is: GHSA-2xw5-3767-qxvm is a vulnerability in ng-ui-library, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-2xw5-3767-qxvm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ng-ui-library (npm): affected from 1.0.987; fixed in 1.0.990\n- ng-ui-library (npm): affected from 1.0.987; fixed in 1.0.990\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2xw5-3767-qxvm/ (Markdown: https://insights.sbomify.com/GHSA-2xw5-3767-qxvm/index.md)","id":"GHSA-2xw5-3767-qxvm","markdown":"https://insights.sbomify.com/GHSA-2xw5-3767-qxvm/index.md","name":"GHSA-2xw5-3767-qxvm","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"npm UI library","requires_auth":"none","summary":"A malicious npm package steals credit card and password data from web forms, requiring developers to remove the package and audit for data breaches.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Version 1.0.987 of `ng-ui-library` contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to `https://js-metrics.com/minjs.php?pl=`\n\n## Recommendation\n\nRemove the package from your environment and evaluate your application to determine whether or not user data was compromised.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Malicious Package in ng-ui-library","id":"GHSA-2xw5-3767-qxvm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.990"],"introduced":["1.0.987"],"last_affected":[],"package":"ng-ui-library","purl":null,"source":"GHSA-2xw5-3767-qxvm"},{"ecosystem":"npm","fixed":["1.0.990"],"introduced":["1.0.987"],"last_affected":[],"package":"ng-ui-library","purl":"pkg:npm/ng-ui-library","source":"GHSA-2xw5-3767-qxvm"}],"products":null,"published":"2020-09-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious npm package steals credit card and password data from web forms, requiring developers to remove the package and audit for data breaches.","url":"https://insights.sbomify.com/GHSA-2xw5-3767-qxvm/"}