{"answers":{"affected":"2 open source packages ship an affected version, including twisted.","exploited":"There is no known exploitation of GHSA-32gv-6cf3-wcmq in the wild and no public exploit code.","fix":"Upgrade twisted to 19.10.0 or later.","what":"GHSA-32gv-6cf3-wcmq is a denial of service vulnerability in twisted, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-32gv-6cf3-wcmq and fix it if it is affected.\n\nWhat it is: GHSA-32gv-6cf3-wcmq is a denial of service vulnerability in twisted, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-32gv-6cf3-wcmq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- twisted (PyPI): affected all versions; fixed in 19.10.0\n- twisted (PyPI): affected all versions; fixed in 19.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-32gv-6cf3-wcmq/ (Markdown: https://insights.sbomify.com/GHSA-32gv-6cf3-wcmq/index.md)","id":"GHSA-32gv-6cf3-wcmq","markdown":"https://insights.sbomify.com/GHSA-32gv-6cf3-wcmq/index.md","name":"GHSA-32gv-6cf3-wcmq","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Python networking library","requires_auth":"none","summary":"Remote attackers can cause denial of service in Twisted web servers with optional HTTP/2 support via ping, reset, or settings floods.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nTwisted web servers that utilize the optional HTTP/2 support suffer from the following flow-control related vulnerabilities:\n\nPing flood: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9512\nReset flood: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9514\nSettings flood: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9515\n\nA Twisted web server supports HTTP/2 requests if you've installed the [`http2` optional dependency set](https://twistedmatrix.com/documents/19.2.0/installation/howto/optional.html).\n\n### Workarounds\nThere are no workarounds.\n\n### References\nhttps://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-002.md\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [Twisted's Trac](https://twistedmatrix.com/trac/)","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"HTTP/2 DoS Attacks: Ping, Reset, and Settings Floods","id":"GHSA-32gv-6cf3-wcmq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["19.10.0"],"introduced":["0"],"last_affected":[],"package":"twisted","purl":null,"source":"GHSA-32gv-6cf3-wcmq"},{"ecosystem":"PyPI","fixed":["19.10.0"],"introduced":["0"],"last_affected":[],"package":"twisted","purl":"pkg:pypi/twisted","source":"GHSA-32gv-6cf3-wcmq"}],"products":null,"published":"2022-03-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote attackers can cause denial of service in Twisted web servers with optional HTTP/2 support via ping, reset, or settings floods.","url":"https://insights.sbomify.com/GHSA-32gv-6cf3-wcmq/"}