{"answers":{"affected":"2 open source packages ship an affected version, including ntpd.","exploited":"There is no known exploitation of GHSA-37xq-q42p-rv3p in the wild and no public exploit code.","fix":"Upgrade ntpd to 0.3.7 or later.","what":"GHSA-37xq-q42p-rv3p is a denial of service vulnerability in ntpd, published on 24 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-37xq-q42p-rv3p and fix it if it is affected.\n\nWhat it is: GHSA-37xq-q42p-rv3p is a denial of service vulnerability in ntpd, published on 24 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-37xq-q42p-rv3p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ntpd (crates.io): affected all versions; fixed in 0.3.7\n- ntpd (crates.io): affected all versions; fixed in 0.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-37xq-q42p-rv3p/ (Markdown: https://insights.sbomify.com/GHSA-37xq-q42p-rv3p/index.md)","id":"GHSA-37xq-q42p-rv3p","markdown":"https://insights.sbomify.com/GHSA-37xq-q42p-rv3p/index.md","name":"GHSA-37xq-q42p-rv3p","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NTP daemon","requires_auth":"none","summary":"An attacker can cause excessive CPU usage on NTP clients using NTS by triggering expensive key validation via a vulnerable dependency.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"During startup, an attacker that can man-in-the-middle traffic to and from NTS key exchange servers can trigger a very expensive key validation process due to a vulnerability in webpki.\n\n### Impact\nThis vulnerability can lead to excessive cpu usage on startup on clients configured to use NTS\n\n### Patches\nAffected users are recommended to upgrade to version 0.3.7\n\n### References\nSee also https://github.com/rustsec/advisory-db/blob/main/crates/rustls-webpki/RUSTSEC-2023-0053.md","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ntpd has Dependency on Vulnerable Third-Party Component","id":"GHSA-37xq-q42p-rv3p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.3.7"],"introduced":["0"],"last_affected":[],"package":"ntpd","purl":null,"source":"GHSA-37xq-q42p-rv3p"},{"ecosystem":"crates.io","fixed":["0.3.7"],"introduced":["0"],"last_affected":[],"package":"ntpd","purl":"pkg:cargo/ntpd","source":"GHSA-37xq-q42p-rv3p"}],"products":null,"published":"2023-08-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause excessive CPU usage on NTP clients using NTS by triggering expensive key validation via a vulnerable dependency.","url":"https://insights.sbomify.com/GHSA-37xq-q42p-rv3p/"}