{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-392f-ggf5-fp3c in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.3.1 or later.","what":"GHSA-392f-ggf5-fp3c is a vulnerability in openclaw, published on 2 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-392f-ggf5-fp3c and fix it if it is affected.\n\nWhat it is: GHSA-392f-ggf5-fp3c is a vulnerability in openclaw, published on 2 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-392f-ggf5-fp3c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.3.1\n- openclaw (npm): affected all versions; fixed in 2026.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-392f-ggf5-fp3c/ (Markdown: https://insights.sbomify.com/GHSA-392f-ggf5-fp3c/index.md)","id":"GHSA-392f-ggf5-fp3c","markdown":"https://insights.sbomify.com/GHSA-392f-ggf5-fp3c/index.md","name":"GHSA-392f-ggf5-fp3c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js security library","requires_auth":"low_privilege","summary":"Attackers can bypass node command allowlists via Unicode confusables in metadata, potentially executing unauthorized system commands.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nA paired node could supply Unicode-confusable `platform` or `deviceFamily` metadata that passed metadata pinning but classified differently for command policy resolution, broadening default node command allowlists.\n\n### Impact\nThis is a policy-bypass issue within the paired-node trust boundary and can expand node command availability beyond intended defaults.\n\n### Fix\nNode metadata canonicalization was hardened against confusables, and unknown platform defaults were made conservative (excluding `system.run` and `system.which` unless explicitly allowlisted).\n\n### Affected and Patched Versions\n- Affected: `\u003c= 2026.2.26`\n- Patched: `2026.3.1`","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw: Unicode canonicalization drift in node metadata policy classification could broaden node allowlists","id":"GHSA-392f-ggf5-fp3c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.3.1"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-392f-ggf5-fp3c"},{"ecosystem":"npm","fixed":["2026.3.1"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-392f-ggf5-fp3c"}],"products":null,"published":"2026-03-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass node command allowlists via Unicode confusables in metadata, potentially executing unauthorized system commands.","url":"https://insights.sbomify.com/GHSA-392f-ggf5-fp3c/"}