{"answers":{"affected":"2 open source packages ship an affected version, including pingora-core.","exploited":"There is no known exploitation of GHSA-393w-9x6h-8gc7 in the wild and no public exploit code.","fix":"Upgrade pingora-core to 0.6.0 or later.","what":"GHSA-393w-9x6h-8gc7 is a denial of service vulnerability in pingora-core, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-393w-9x6h-8gc7 and fix it if it is affected.\n\nWhat it is: GHSA-393w-9x6h-8gc7 is a denial of service vulnerability in pingora-core, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-393w-9x6h-8gc7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pingora-core (crates.io): affected all versions; fixed in 0.6.0\n- pingora-core (crates.io): affected all versions; fixed in 0.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-393w-9x6h-8gc7/ (Markdown: https://insights.sbomify.com/GHSA-393w-9x6h-8gc7/index.md)","id":"GHSA-393w-9x6h-8gc7","markdown":"https://insights.sbomify.com/GHSA-393w-9x6h-8gc7/index.md","name":"GHSA-393w-9x6h-8gc7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust HTTP proxy library","requires_auth":"none","summary":"Malicious clients can cause excessive memory consumption and denial of service in Pingora HTTP/2 servers by triggering repeated resets.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Pingora deployments that include HTTP/2 server support may be affected by the vulnerability described in CVE-2025-8671. Under certain conditions, Pingora applications may allocate buffers before the HTTP/2 reset and resulting stream cancellation is processed by the server. Repeated resets can force excessive memory consumption and lead to denial-of-service.\n\n**Impact**:\nOn affected versions, malicious clients could trigger unusually high memory consumption, which may result in service instability or process termination.\n\n**Credits**:\nReported responsibly by security researcher [Gal Bar Nahum](https://github.com/galbarnahum) (@[galbarnahum](https://github.com/galbarnahum))\n\n**Mitigation**:\nThis issue is addressed by ensuring Pingora uses patched versions of HTTP/2 dependencies that include reset-handling safeguards to release connection resources before excessive memory buildup. Users should upgrade to the latest Pingora release, which incorporates the required fixes.\n- Users are requested to upgrade to latest version of Pingora \u003e= 0.6.0","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Pingora update for MadeYouReset HTTP/2 vulnerability","id":"GHSA-393w-9x6h-8gc7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.6.0"],"introduced":["0"],"last_affected":[],"package":"pingora-core","purl":null,"source":"GHSA-393w-9x6h-8gc7"},{"ecosystem":"crates.io","fixed":["0.6.0"],"introduced":["0"],"last_affected":[],"package":"pingora-core","purl":"pkg:cargo/pingora-core","source":"GHSA-393w-9x6h-8gc7"}],"products":null,"published":"2025-09-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Malicious clients can cause excessive memory consumption and denial of service in Pingora HTTP/2 servers by triggering repeated resets.","url":"https://insights.sbomify.com/GHSA-393w-9x6h-8gc7/"}