GHSA-39hc-v87j-747x Vulnerable OpenSSL included in cryptography wheels

Not scored Published

Attackers can exploit vulnerabilities in the bundled OpenSSL library within Python cryptography wheels to execute code or read data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-39hc-v87j-747x?

GHSA-39hc-v87j-747x is a vulnerability in cryptography, published on 2 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 37.0.0-38.0.3 are vulnerable to a number of security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20221101.txt.

If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Which versions are affected by GHSA-39hc-v87j-747x?

2 open source packages ship an affected version, including cryptography.

PackageAffectedFixed in
cryptography PyPIFrom 37.0.038.0.3
cryptography PyPIFrom 37.0.038.0.3

How do I fix GHSA-39hc-v87j-747x?

Upgrade cryptography to 38.0.3 or later.

Is GHSA-39hc-v87j-747x being exploited?

There is no known exploitation of GHSA-39hc-v87j-747x in the wild and no public exploit code.

Sources

Is GHSA-39hc-v87j-747x in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free