# GHSA-3cv2-h65g-fgmm: astral-tokio-tar has a PAX Header Desynchronization issue

> Attackers can smuggle unexpected files onto a victim's filesystem by exploiting a PAX header desynchronization bug in the astral-tokio-tar library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 May 2026
- **Also known as:** RUSTSEC-2026-0145

## What is GHSA-3cv2-h65g-fgmm?

GHSA-3cv2-h65g-fgmm is a path traversal vulnerability in astral-tokio-tar, published on 18 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

### Impact

Versions of astral-tokio-tar prior to 0.6.2 contain a PAX header interpretation bug that allows manipulated entries to be made selectively visible or invisible during extraction with astral-tokio-tar versus other tar implementations. An attacker could use this differential to smuggle unexpected files onto a victim's filesystem.

### Details

When a tar stream contains multiple "header" entries prior to a file entry, astral-tokio-tar applies the PAX header (`x`) to the next entry in the stream, regardless of type. For example, a stream of `x -> L -> file` (PAX, GNU longname, file) would result in `x`'s extensions being applied to `L` rather than to `file`.

[Per POSIX pax](https://pubs.opengroup.org/onlinepubs/9799919799/utilities/pax.html), this is incorrect: a PAX header always applies to a file entry, not any intermediary entries. See the "pax Header Block" section for the specific prescription there.

As a result of this, an attacker can contrive a tar containing a sequence of tar headers such that astral-tokio-tar applies the PAX header's size extension to the next header in sequence, effectively desynchronizing the stream and enabling astral-tokio-tar specific skippage/extraction of members. In other words, a file can be contrived to extract differently on astral-tokio-tar than on other tar parsers.

### Patches

Versions 0.6.2 and newer of astral-tokio-tar address this differential.

### Workarounds

Users are advised to upgrade to version 0.6.1 or newer to address this advisory.

There is no workaround other than upgrading. Users should experience no breaking changes as a result of the upgrade.

### Resources

- GHSA-j5gw-2vrg-8fgx is a similar PAX desynchronization bug
- GHSA-fp55-jw48-c537 is another similar PAX desynchronization bug

## Which versions are affected by GHSA-3cv2-h65g-fgmm?

3 open source packages ship an affected version, including astral-tokio-tar.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `astral-tokio-tar` | crates.io | All versions | 0.6.2 |
| `astral-tokio-tar` | crates.io | All versions | 0.6.2 |
| `astral-tokio-tar` | crates.io | From 0.0.0-0 | 0.6.2 |

## How do I fix GHSA-3cv2-h65g-fgmm?

Upgrade astral-tokio-tar to 0.6.2 or later.

## Is GHSA-3cv2-h65g-fgmm being exploited?

There is no known exploitation of GHSA-3cv2-h65g-fgmm in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-3cv2-h65g-fgmm and fix it if it is affected.

What it is: GHSA-3cv2-h65g-fgmm is a path traversal vulnerability in astral-tokio-tar, published on 18 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-3cv2-h65g-fgmm in the wild and no public exploit code.

Affected packages and fixed versions:
- astral-tokio-tar (crates.io): affected all versions; fixed in 0.6.2
- astral-tokio-tar (crates.io): affected all versions; fixed in 0.6.2
- astral-tokio-tar (crates.io): affected from 0.0.0-0; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-3cv2-h65g-fgmm/ (Markdown: https://insights.sbomify.com/GHSA-3cv2-h65g-fgmm/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-3cv2-h65g-fgmm

---
From sbomify Insights: https://insights.sbomify.com/GHSA-3cv2-h65g-fgmm/
Summaries are generated and may contain mistakes; the official description above is the record.
