{"answers":{"affected":"2 open source packages ship an affected version, including paragonie/random_compat.","exploited":"There is no known exploitation of GHSA-3fmq-x9q6-wm39 in the wild and no public exploit code.","fix":"Upgrade paragonie/random_compat to 2.0 or later.","what":"GHSA-3fmq-x9q6-wm39 is a vulnerability in paragonie/random_compat, published on 17 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3fmq-x9q6-wm39 and fix it if it is affected.\n\nWhat it is: GHSA-3fmq-x9q6-wm39 is a vulnerability in paragonie/random_compat, published on 17 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3fmq-x9q6-wm39 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paragonie/random_compat (Packagist): affected all versions; fixed in 2.0\n- paragonie/random_compat (Packagist): affected all versions; fixed in 2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3fmq-x9q6-wm39/ (Markdown: https://insights.sbomify.com/GHSA-3fmq-x9q6-wm39/index.md)","id":"GHSA-3fmq-x9q6-wm39","markdown":"https://insights.sbomify.com/GHSA-3fmq-x9q6-wm39/index.md","name":"GHSA-3fmq-x9q6-wm39","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP random library","requires_auth":"none","summary":"The random_compat library uses an insecure CSPRNG, potentially generating predictable random numbers that compromise security.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"random_compat versions prior to 2.0 are affected by a security vulnerability related to the insecure usage of Cryptographically Secure Pseudo-Random Number Generators (CSPRNG). The affected versions use openssl_random_pseudo_bytes(), which may result in insufficient entropy and compromise the security of generated random numbers.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"random_compat Uses insecure CSPRNG","id":"GHSA-3fmq-x9q6-wm39","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.0"],"introduced":["0"],"last_affected":[],"package":"paragonie/random_compat","purl":null,"source":"GHSA-3fmq-x9q6-wm39"},{"ecosystem":"Packagist","fixed":["2.0"],"introduced":["0"],"last_affected":[],"package":"paragonie/random_compat","purl":"pkg:composer/paragonie/random_compat","source":"GHSA-3fmq-x9q6-wm39"}],"products":null,"published":"2024-05-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The random_compat library uses an insecure CSPRNG, potentially generating predictable random numbers that compromise security.","url":"https://insights.sbomify.com/GHSA-3fmq-x9q6-wm39/"}