# GHSA-3g43-xfrw-pv5m: eZ Platform User data disclosure

> Unauthenticated attackers can bypass permission checks to read user data like names and emails in eZ Platform.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2024

## What is GHSA-3g43-xfrw-pv5m?

GHSA-3g43-xfrw-pv5m is a missing authorization vulnerability in ezsystems/repository-forms, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In eZ Platform v2.3.x it is possible to bypass permission checks in a particular case. This means user data such as name and email (but not passwords or password hashes) can be read by unauthenticated users. This affects only v2.3.x. If you use v2.2.x or older you are not affected.

To install, use Composer to update "ezsystems/repository-forms" to the "Resolving versions" mentioned above, or apply this patch manually:
https://github.com/ezsystems/repository-forms/commit/ea82e136ec1ea40aca714abb79cc8e5bfece01e8

Have you found a security bug in eZ Publish or eZ Platform? See how to report it responsibly here: https://doc.ez.no/Security

## Which versions are affected by GHSA-3g43-xfrw-pv5m?

2 open source packages ship an affected version, including ezsystems/repository-forms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/repository-forms` | Packagist | From 2.3.0 | 2.3.2.1 |
| `ezsystems/repository-forms` | Packagist | From 2.3.0 | 2.3.2.1 |

## How do I fix GHSA-3g43-xfrw-pv5m?

Upgrade ezsystems/repository-forms to 2.3.2.1 or later.

## Is GHSA-3g43-xfrw-pv5m being exploited?

There is no known exploitation of GHSA-3g43-xfrw-pv5m in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-3g43-xfrw-pv5m and fix it if it is affected.

What it is: GHSA-3g43-xfrw-pv5m is a missing authorization vulnerability in ezsystems/repository-forms, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-3g43-xfrw-pv5m in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/repository-forms (Packagist): affected from 2.3.0; fixed in 2.3.2.1
- ezsystems/repository-forms (Packagist): affected from 2.3.0; fixed in 2.3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-3g43-xfrw-pv5m/ (Markdown: https://insights.sbomify.com/GHSA-3g43-xfrw-pv5m/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-3g43-xfrw-pv5m

---
From sbomify Insights: https://insights.sbomify.com/GHSA-3g43-xfrw-pv5m/
Summaries are generated and may contain mistakes; the official description above is the record.
