{"answers":{"affected":"3 open source packages ship an affected version, including tokio-postgres.","exploited":"There is no known exploitation of GHSA-3gjw-f78c-vvpw in the wild and no public exploit code.","fix":"Upgrade tokio-postgres to 0.7.18 or later.","what":"GHSA-3gjw-f78c-vvpw is a denial of service vulnerability in tokio-postgres, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3gjw-f78c-vvpw and fix it if it is affected.\n\nWhat it is: GHSA-3gjw-f78c-vvpw is a denial of service vulnerability in tokio-postgres, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3gjw-f78c-vvpw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tokio-postgres (crates.io): affected from 0.4.0; fixed in 0.7.18\n- tokio-postgres (crates.io): affected from 0.4.0; fixed in 0.7.18\n- tokio-postgres (crates.io): affected from 0.4.0; fixed in 0.7.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3gjw-f78c-vvpw/ (Markdown: https://insights.sbomify.com/GHSA-3gjw-f78c-vvpw/index.md)","id":"GHSA-3gjw-f78c-vvpw","markdown":"https://insights.sbomify.com/GHSA-3gjw-f78c-vvpw/index.md","name":"GHSA-3gjw-f78c-vvpw","record":{"aliases":["RUSTSEC-2026-0178"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust database client","requires_auth":"none","summary":"A malicious server can cause a denial of service by sending malformed data rows, crashing the Rust database client application.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A malicious or compromised server can send a row containing fewer fields than\nits row description declares columns. Reading one of the missing columns then\npanics with an out-of-bounds index, aborting the calling task. This affects even\nthe otherwise non-panicking `try_get`, and both `Row` and `SimpleQueryRow`.\n\nApplications that connect only to a trusted database are not exposed; the risk\napplies to clients that may connect to untrusted or user-supplied servers, or\nwhose connection can be intercepted by a man-in-the-middle.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Panic on a `DataRow` with fewer fields than columns allows denial of service","id":"GHSA-3gjw-f78c-vvpw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.7.18"],"introduced":["0.4.0"],"last_affected":[],"package":"tokio-postgres","purl":null,"source":"GHSA-3gjw-f78c-vvpw"},{"ecosystem":"crates.io","fixed":["0.7.18"],"introduced":["0.4.0"],"last_affected":[],"package":"tokio-postgres","purl":"pkg:cargo/tokio-postgres","source":"GHSA-3gjw-f78c-vvpw"},{"ecosystem":"crates.io","fixed":["0.7.18"],"introduced":["0.4.0"],"last_affected":[],"package":"tokio-postgres","purl":"pkg:cargo/tokio-postgres","source":"RUSTSEC-2026-0178"}],"products":null,"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious server can cause a denial of service by sending malformed data rows, crashing the Rust database client application.","url":"https://insights.sbomify.com/GHSA-3gjw-f78c-vvpw/"}