# GHSA-3gxf-9r58-2ghg: `openssl` `X509NameBuilder::build` returned object is not thread safe

> A race condition in the Rust OpenSSL bindings' X509NameBuilder can lead to memory corruption or crashes when used concurrently.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2023
- **Also known as:** RUSTSEC-2023-0022

## What is GHSA-3gxf-9r58-2ghg?

GHSA-3gxf-9r58-2ghg is a vulnerability in openssl, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSSL has a `modified` bit that it can set on on `X509_NAME` objects. If this bit is set then the object is not thread-safe even when it appears the code is not modifying the value.

Thanks to David Benjamin (Google) for reporting this issue.

## Which versions are affected by GHSA-3gxf-9r58-2ghg?

3 open source packages ship an affected version, including openssl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.0.0-0 | 0.10.48 |
| `openssl` | crates.io | From 0.9.7 | 0.10.48 |
| `openssl` | crates.io | From 0.9.7 | 0.10.48 |

## How do I fix GHSA-3gxf-9r58-2ghg?

Upgrade openssl to 0.10.48 or later.

## Is GHSA-3gxf-9r58-2ghg being exploited?

There is no known exploitation of GHSA-3gxf-9r58-2ghg in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-3gxf-9r58-2ghg and fix it if it is affected.

What it is: GHSA-3gxf-9r58-2ghg is a vulnerability in openssl, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-3gxf-9r58-2ghg in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.0.0-0; fixed in 0.10.48
- openssl (crates.io): affected from 0.9.7; fixed in 0.10.48
- openssl (crates.io): affected from 0.9.7; fixed in 0.10.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-3gxf-9r58-2ghg/ (Markdown: https://insights.sbomify.com/GHSA-3gxf-9r58-2ghg/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-3gxf-9r58-2ghg

---
From sbomify Insights: https://insights.sbomify.com/GHSA-3gxf-9r58-2ghg/
Summaries are generated and may contain mistakes; the official description above is the record.
