{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-3h2q-j2v4-6w5r in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.3.7 or later.","what":"GHSA-3h2q-j2v4-6w5r is a vulnerability in openclaw, published on 9 Mar 2026."},"fix_prompt":"Check this codebase for GHSA-3h2q-j2v4-6w5r and fix it if it is affected.\n\nWhat it is: GHSA-3h2q-j2v4-6w5r is a vulnerability in openclaw, published on 9 Mar 2026. \nExploitation: There is no known exploitation of GHSA-3h2q-j2v4-6w5r in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.3.7\n- openclaw (npm): affected all versions; fixed in 2026.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3h2q-j2v4-6w5r/ (Markdown: https://insights.sbomify.com/GHSA-3h2q-j2v4-6w5r/index.md)","id":"GHSA-3h2q-j2v4-6w5r","markdown":"https://insights.sbomify.com/GHSA-3h2q-j2v4-6w5r/index.md","name":"GHSA-3h2q-j2v4-6w5r","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"unknown","non_default_config":true,"product_category":"OpenClaw npm library","requires_auth":"low_privilege","summary":"Attackers with system.run access can bypass allowlist approval to execute PowerShell payloads via encoded commands in OpenClaw.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"OpenClaw's `system.run` shell-wrapper detection did not recognize PowerShell `-EncodedCommand` forms as inline-command wrappers.\n\nIn `allowlist` mode, a caller with access to `system.run` could invoke `pwsh` or `powershell` using `-EncodedCommand`, `-enc`, or `-e`, and the request would fall back to plain argv analysis instead of the normal shell-wrapper approval path. This could allow a PowerShell inline payload to execute without the approval step that equivalent `-Command` invocations would require.\n\nLatest published npm version: `2026.3.2`\n\nFixed on `main` on March 7, 2026 in `1d1757b16f48f1a93cd16ab0ad7e2c3c63ce727d` by recognizing PowerShell encoded-command aliases during shell-wrapper parsing, so allowlist mode continues to require approval for those payloads. Normal approved PowerShell wrapper flows continue to work.\n\n## Affected Packages / Versions\n\n- Package: `openclaw` (npm)\n- Affected versions: `\u003c= 2026.3.2`\n- Patched version: `\u003e= 2026.3.7`\n\n## Fix Commit(s)\n\n- `1d1757b16f48f1a93cd16ab0ad7e2c3c63ce727d`\n\n## Release Process Note\n\nnpm `2026.3.7` was published on March 8, 2026. This advisory is fixed in the released package.\n\nThanks @tdjackey for reporting.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw's system.run allowlist approval parsing missed PowerShell encoded-command wrappers","id":"GHSA-3h2q-j2v4-6w5r","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.3.7"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-3h2q-j2v4-6w5r"},{"ecosystem":"npm","fixed":["2026.3.7"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-3h2q-j2v4-6w5r"}],"products":null,"published":"2026-03-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers with system.run access can bypass allowlist approval to execute PowerShell payloads via encoded commands in OpenClaw.","url":"https://insights.sbomify.com/GHSA-3h2q-j2v4-6w5r/"}