# GHSA-3h5r-928v-mxhh: Unauthorized client-side property update in UIDL request handler in Vaadin 10 and 11

> An attacker can modify client-side element properties in Vaadin applications due to missing authorization checks in the UIDL request handler.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2021

## What is GHSA-3h5r-928v-mxhh?

GHSA-3h5r-928v-mxhh is a missing authorization vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Missing check in UIDL request handler in `com.vaadin:flow-server` versions 1.0.0 through 1.0.5 (Vaadin 10.0.0 through 10.0.7, and 11.0.0 through 11.0.2) allows attacker to update element property values via crafted synchronization message.

- https://vaadin.com/security/cve-2018-25007

## Which versions are affected by GHSA-3h5r-928v-mxhh?

4 open source packages ship an affected version, including com.vaadin:vaadin-bom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 10.0.0 | 10.0.8 |
| `com.vaadin:vaadin-bom` | Maven | From 10.0.0 | 10.0.8 |
| `com.vaadin:vaadin-bom` | Maven | From 11.0.0 | 11.0.3 |
| `com.vaadin:vaadin-bom` | Maven | From 11.0.0 | 11.0.3 |

## How do I fix GHSA-3h5r-928v-mxhh?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 10.0.8 or 11.0.3.

## Is GHSA-3h5r-928v-mxhh being exploited?

There is no known exploitation of GHSA-3h5r-928v-mxhh in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-3h5r-928v-mxhh and fix it if it is affected.

What it is: GHSA-3h5r-928v-mxhh is a missing authorization vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-3h5r-928v-mxhh in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 10.0.0; fixed in 10.0.8
- com.vaadin:vaadin-bom (Maven): affected from 10.0.0; fixed in 10.0.8
- com.vaadin:vaadin-bom (Maven): affected from 11.0.0; fixed in 11.0.3
- com.vaadin:vaadin-bom (Maven): affected from 11.0.0; fixed in 11.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-3h5r-928v-mxhh/ (Markdown: https://insights.sbomify.com/GHSA-3h5r-928v-mxhh/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-3h5r-928v-mxhh

---
From sbomify Insights: https://insights.sbomify.com/GHSA-3h5r-928v-mxhh/
Summaries are generated and may contain mistakes; the official description above is the record.
