GHSA-3hfp-gqgh-xc5g Axios supply chain attack - dependency in @lightdash/cli may resolve to compromised axios versions
A supply chain attack on Axios allowed attackers to install a remote access trojan via the Lightdash CLI, granting full system control and credential theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-3hfp-gqgh-xc5g?
GHSA-3hfp-gqgh-xc5g is a vulnerability in @lightdash/cli, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Impact
A supply chain attack on the axios npm package (versions 1.14.1 and 0.30.4) introduced a malicious transitive dependency ([email protected]) that deploys a cross-platform remote access trojan (RAT) on macOS, Windows, and Linux. The attacker compromised the primary axios maintainer's npm account to publish the malicious versions.
The malicious versions were live on npm for approximately 3 hours (00:21 UTC to 03:29 UTC on March 31, 2026) before being removed.
The @lightdash/cli package specified axios as a dependency with a semver range (^1.12.0) that permitted resolution to the compromised version. Any user who performed a fresh install of @lightdash/cli versions >= 0.1800.0, < 0.2695.1 (without a pre-existing lockfile) during this window may have installed the malicious axios version.
If compromised, the RAT establishes a connection to a command-and-control server (sfrclak[.]com / 142.11.206.73:8000) and provides the attacker with shell access, file system enumeration, and the ability to execute arbitrary commands. All credentials, secrets, and tokens accessible from the affected machine should be considered compromised.
Lightdash Cloud is not affected.
Patches
This has been patched in @lightdash/[email protected]. The fix pins axios to a known safe version (1.14.0).
Users should upgrade immediately:
npm install -g @lightdash/[email protected]
If users had installed the compromised version, they should check for RAT artifacts before and after upgrading:
- macOS:
/Library/Caches/com.apple.act.mond - Windows:
%PROGRAMDATA%\wt.exe - Linux:
/tmp/ld.py
If any artifacts are found, assume full compromise of that machine and rotate all accessible credentials (warehouse credentials, API tokens, SSH keys, cloud provider credentials, environment variables).
Workarounds
If users cannot upgrade immediately, they can force a safe axios resolution after installing the CLI:
npm install -g [email protected] --force
Alternatively, if users are building a Docker image or using a lockfile, they should ensure their resolved axios version is not 1.14.1 or 0.30.4:
npm ls axios
Block egress traffic to sfrclak[.]com and 142.11.206.73 at the network level to prevent the RAT from reaching its command-and-control server.
Resources
- Upstream axios issue: https://github.com/axios/axios/issues/10604
- StepSecurity analysis: https://www.stepsecurity.io/blog/axios-compromised-on-npm-malicious-versions-drop-remote-access-trojan
- Socket analysis: https://socket.dev/blog/axios-npm-package-compromised
- Snyk advisory (axios): https://security.snyk.io/vuln/SNYK-JS-AXIOS-15850650
- Snyk advisory (plain-crypto-js): https://security.snyk.io/vuln/SNYK-JS-PLAINCRYPTOJS-15850652
- The Hacker News coverage: https://thehackernews.com/2026/03/axios-supply-chain-attack-pushes-cross.html
Which versions are affected by GHSA-3hfp-gqgh-xc5g?
2 open source packages ship an affected version, including @lightdash/cli.
| Package | Affected | Fixed in |
|---|---|---|
@lightdash/cli npm | From 0.1800.0 | 0.2695.1 |
@lightdash/cli npm | From 0.1800.0 | 0.2695.1 |
How do I fix GHSA-3hfp-gqgh-xc5g?
Upgrade @lightdash/cli to 0.2695.1 or later.
Is GHSA-3hfp-gqgh-xc5g being exploited?
There is no known exploitation of GHSA-3hfp-gqgh-xc5g in the wild and no public exploit code.