{"answers":{"affected":"8 open source packages ship an affected version, including x402, x402-express and x402-hono.","exploited":"There is no known exploitation of GHSA-3j63-5h8p-gf7c in the wild and no public exploit code.","fix":"Upgrade x402 to 0.5.2 or later.","what":"GHSA-3j63-5h8p-gf7c is a vulnerability in x402, published on 20 Aug 2025. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-3j63-5h8p-gf7c and fix it if it is affected.\n\nWhat it is: GHSA-3j63-5h8p-gf7c is a vulnerability in x402, published on 20 Aug 2025. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-3j63-5h8p-gf7c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- x402 (npm): affected all versions; fixed in 0.5.2\n- x402 (npm): affected all versions; fixed in 0.5.2\n- x402-express (npm): affected all versions; fixed in 0.5.2\n- x402-express (npm): affected all versions; fixed in 0.5.2\n- x402-hono (npm): affected all versions; fixed in 0.5.2\n- x402-hono (npm): affected all versions; fixed in 0.5.2\n- x402-next (npm): affected all versions; fixed in 0.5.2\n- x402-next (npm): affected all versions; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3j63-5h8p-gf7c/ (Markdown: https://insights.sbomify.com/GHSA-3j63-5h8p-gf7c/index.md)","id":"GHSA-3j63-5h8p-gf7c","markdown":"https://insights.sbomify.com/GHSA-3j63-5h8p-gf7c/index.md","name":"GHSA-3j63-5h8p-gf7c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"x402 SDK","requires_auth":"unknown","summary":"Outdated x402 SDK versions pose a security risk to builders operating resource servers, requiring an upgrade to patched versions.","user_interaction":"unknown","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThere is a security vulnerability in outdated versions of the x402 SDK. This does not directly affect users' keys, smart contracts, or funds.\n\nThis primarily impacts builders working on resource servers.\n\n### Patches\nPlease update to the following package versions:\n* x402 \u003e= 0.5.2\n* x402-next \u003e= 0.5.2\n* x402-express \u003e= 0.5.2\n* x402-hono \u003e= 0.5.2","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"x402 SDK vulnerable in outdated versions in resource servers for builders","id":"GHSA-3j63-5h8p-gf7c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2025"},"n_packages":8,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"x402","purl":null,"source":"GHSA-3j63-5h8p-gf7c"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"x402","purl":"pkg:npm/x402","source":"GHSA-3j63-5h8p-gf7c"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"x402-express","purl":null,"source":"GHSA-3j63-5h8p-gf7c"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"x402-express","purl":"pkg:npm/x402-express","source":"GHSA-3j63-5h8p-gf7c"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"x402-hono","purl":null,"source":"GHSA-3j63-5h8p-gf7c"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"x402-hono","purl":"pkg:npm/x402-hono","source":"GHSA-3j63-5h8p-gf7c"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"x402-next","purl":null,"source":"GHSA-3j63-5h8p-gf7c"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"x402-next","purl":"pkg:npm/x402-next","source":"GHSA-3j63-5h8p-gf7c"}],"products":null,"published":"2025-08-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Outdated x402 SDK versions pose a security risk to builders operating resource servers, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/GHSA-3j63-5h8p-gf7c/"}