{"answers":{"affected":"3 open source packages ship an affected version, including flatbuffers.","exploited":"There is no known exploitation of GHSA-3jch-9qgp-4844 in the wild and no public exploit code.","fix":"Upgrade flatbuffers to 22.9.29 or later.","what":"GHSA-3jch-9qgp-4844 is a memory corruption vulnerability in flatbuffers, published on 31 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3jch-9qgp-4844 and fix it if it is affected.\n\nWhat it is: GHSA-3jch-9qgp-4844 is a memory corruption vulnerability in flatbuffers, published on 31 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3jch-9qgp-4844 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flatbuffers (crates.io): affected all versions; fixed in 22.9.29\n- flatbuffers (crates.io): affected all versions; fixed in 22.9.29\n- flatbuffers (crates.io): affected from 0.0.0-0; fixed in 22.9.29\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3jch-9qgp-4844/ (Markdown: https://insights.sbomify.com/GHSA-3jch-9qgp-4844/index.md)","id":"GHSA-3jch-9qgp-4844","markdown":"https://insights.sbomify.com/GHSA-3jch-9qgp-4844/index.md","name":"GHSA-3jch-9qgp-4844","record":{"aliases":["RUSTSEC-2021-0122"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust serialization library","requires_auth":"none","summary":"Attackers can trigger memory corruption and potential code execution by providing malformed input to unsafe code generated by the flatbuffers compiler.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Code generated by flatbuffers' compiler is `unsafe` but not marked as such.\nSee https://github.com/google/flatbuffers/issues/6627 for details.\n\nFor example, if generated code is used to decode malformed or untrusted input,\nundefined behavior (and thus security vulnerabilities) is possible even without\nthe use of the `unsafe` keyword, [violating the the meaning of \"safe\"](https://doc.rust-lang.org/std/keyword.unsafe.html#the-different-meanings-of-unsafe) code;\n\nAll users that use generated code by `flatbuffers` compiler are recommended to:\n1. not expose flatbuffer generated code as part of their public APIs\n2. audit their code and look for any usage of `follow`, `push`, or any method that uses them\n   (e.g. `self_follow`).\n3. Carefully go through the crates' documentation to understand which \"safe\" APIs are not\n   intended to be used.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Generated code can read and write out of bounds in safe code","id":"GHSA-3jch-9qgp-4844","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2021"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["22.9.29"],"introduced":["0"],"last_affected":[],"package":"flatbuffers","purl":null,"source":"GHSA-3jch-9qgp-4844"},{"ecosystem":"crates.io","fixed":["22.9.29"],"introduced":["0"],"last_affected":[],"package":"flatbuffers","purl":"pkg:cargo/flatbuffers","source":"GHSA-3jch-9qgp-4844"},{"ecosystem":"crates.io","fixed":["22.9.29"],"introduced":["0.0.0-0"],"last_affected":[],"package":"flatbuffers","purl":"pkg:cargo/flatbuffers","source":"RUSTSEC-2021-0122"}],"products":null,"published":"2021-10-31","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can trigger memory corruption and potential code execution by providing malformed input to unsafe code generated by the flatbuffers compiler.","url":"https://insights.sbomify.com/GHSA-3jch-9qgp-4844/"}